DHKEM(X25519, HKDF-SHA256)
DHKEM(X25519, HKDF-SHA256) は、ECH、MLS、Oblivious HTTP で使われる HPKE の KEM です。
HPKE(RFC 9180)は、X25519 の一時鍵を使ったカプセル化によって Diffie–Hellman を KEM に変えます。32 バイトのカプセル化鍵は、送信者の一時公開鍵です。Encrypted Client Hello の設定では、これがデフォルトの KEM です。
28 件中 28 件を表示
ハイブリッド公開鍵暗号化(RFC 9180)の鍵カプセル化メカニズムです。ML-KEM とハイブリッド方式も含みます。
| 値 | 名称 | Nenc | Npk | Nsk | Nsecret | 認証モード | 参考文献 |
|---|---|---|---|---|---|---|---|
0x0010 | DHKEM(P-256, HKDF-SHA256)P-256 | 65 | 65 | 32 | 32 | はい | FIPS 186-4RFC 5869 |
0x0011 | DHKEM(P-384, HKDF-SHA384)P-384 | 97 | 97 | 48 | 48 | はい | FIPS 186-4RFC 5869 |
0x0012 | DHKEM(P-521, HKDF-SHA512)P-521 | 133 | 133 | 66 | 64 | はい | FIPS 186-4RFC 5869 |
0x0013 | DHKEM(CP-256, HKDF-SHA256)P-256 | 32 | 32 | 32 | 32 | はい | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0014 | DHKEM(CP-384, HKDF-SHA384)P-384 | 48 | 48 | 48 | 48 | はい | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0015 | DHKEM(CP-521, HKDF-SHA512)P-521 | 66 | 66 | 66 | 64 | はい | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0016 | DHKEM(secp256k1, HKDF-SHA256)secp256k1 | 65 | 65 | 32 | 32 | はい | SEC 2draft-wahby-cfrg-hpke-kem-secp256k1-01 |
0x0020注記 | DHKEM(X25519, HKDF-SHA256)curve25519 | 32 | 32 | 32 | 32 | はい | RFC 5869RFC 7748 |
0x0021 | DHKEM(X448, HKDF-SHA512)curve448 | 56 | 56 | 56 | 64 | はい | RFC 5869RFC 7748 |
0x0022 | DHKEM(X25519+Elligator, HKDF-SHA256)curve25519 | 32 | 32 | 32 | 32 | はい | lsd.gnunet.org/lsd0011draft-schanzen-hpke-elligator-kem-01 |
0x0030 | X25519Kyber768Draft00curve25519 | 1120 | 1216 | 2432 | 64 | いいえ | draft-westerbaan-cfrg-hpke-xyber768d00-02 |
0x0040 | ML-KEM-512 | 768 | 800 | 64 | 32 | いいえ | draft-connolly-cfrg-hpke-mlkem-04 |
0x0041 | ML-KEM-768 | 1088 | 1184 | 64 | 32 | いいえ | draft-connolly-cfrg-hpke-mlkem-04 |
0x0042 | ML-KEM-1024 | 1568 | 1568 | 64 | 32 | いいえ | draft-connolly-cfrg-hpke-mlkem-04 |
0x0050 | MLKEM768-P256P-256 | 1153 | 1249 | 32 | 32 | いいえ | draft-ietf-hpke-pq-04 |
0x0051 | MLKEM1024-P384P-384 | 1665 | 1665 | 32 | 32 | いいえ | draft-ietf-hpke-pq-04 |
0x647A注記 | X-Wingcurve25519 | 1120 | 1216 | 32 | 32 | いいえ | draft-connolly-cfrg-xwing-kem-06 |
| 範囲 | ステータス | 説明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0001–0x000F | unassigned | Unassigned |
| 0x0017–0x001F | unassigned | Unassigned |
| 0x0023–0x002F | unassigned | Unassigned |
| 0x0031–0x003F | unassigned | Unassigned |
| 0x0043–0x004F | unassigned | Unassigned |
| 0x0052–0x6479 | unassigned | Unassigned |
| 0x647B–0xFFFF | unassigned | Unassigned |
出典:Hybrid Public Key Encryption (HPKE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 HPKE KEM Identifiers
DHKEM(X25519, HKDF-SHA256) は、ECH、MLS、Oblivious HTTP で使われる HPKE の KEM です。
HPKE(RFC 9180)は、X25519 の一時鍵を使ったカプセル化によって Diffie–Hellman を KEM に変えます。32 バイトのカプセル化鍵は、送信者の一時公開鍵です。Encrypted Client Hello の設定では、これがデフォルトの KEM です。
X-Wing は ML-KEM-768 と X25519 を組み合わせたハイブリッド KEM で、HPKE 用に登録されています。
X-Wing(draft-connolly-cfrg-xwing-kem)は、ML-KEM-768 の共有秘密、X25519 の共有秘密、X25519 の公開値を SHA3-256 に通して 32 バイトの共有秘密を導出します。これにより、どちらかの構成要素が安全である限り安全性が保たれる単一の KEM になります。カプセル化鍵は 1,120 バイト、公開鍵は 1,216 バイトです。
HPKE の鍵導出関数です。
| 値 | 名称 | Nh | 参考文献 |
|---|---|---|---|
0x0001 | HKDF-SHA256 | 32 | RFC 5869 |
0x0002 | HKDF-SHA384 | 48 | RFC 5869 |
0x0003 | HKDF-SHA512 | 64 | RFC 5869 |
0x0010 | SHAKE128 | 32 | draft-ietf-hpke-pq-04 |
0x0011 | SHAKE256 | 64 | draft-ietf-hpke-pq-04 |
0x0012 | TurboSHAKE128 | 32 | draft-ietf-hpke-pq-04 |
0x0013 | TurboSHAKE256 | 64 | draft-ietf-hpke-pq-04 |
| 範囲 | ステータス | 説明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0004–0x000F | unassigned | Unassigned |
| 0x0014–0xFFFF | unassigned | Unassigned |
出典:Hybrid Public Key Encryption (HPKE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 HPKE KDF Identifiers
HPKE の認証付き暗号アルゴリズムです。
| 値 | 名称 | Nk | Nn | Nt | 参考文献 |
|---|---|---|---|---|---|
0x0001 | AES-128-GCM | 16 | 12 | 16 | NIST SP 800-38D |
0x0002 | AES-256-GCM | 32 | 12 | 16 | NIST SP 800-38D |
0x0003 | ChaCha20Poly1305 | 32 | 12 | 16 | RFC 8439 |
0xFFFF | Export-only | — | — | — | RFC 9180 |
| 範囲 | ステータス | 説明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0004–0xFFFE | unassigned | Unassigned |
出典:Hybrid Public Key Encryption (HPKE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 HPKE AEAD Identifiers