brainpoolP256r1 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 256 位素域上,其素数阶子群为 256 位,余因子为 1;估计安全级别为 128 位。状态:安全,但仅限特定地区或小众场景。
Brainpool 曲线(RFC 5639)以可验证的伪随机方式生成:素数取自 π 的各位数字,曲线系数取自 e 的各位数字,因此任何人都可以重新计算它们(RFC 5639 附录 A)。brainpoolP256r1 是其中的 256 位随机曲线,阶为素数(余因子为 1),安全强度约为 128 位。
TLS 通过 RFC 7027(TLS 1.2)和 RFC 8734(TLS 1.3,组 brainpoolP256r1tls13,签名方案 ecdsa_brainpoolP256r1tls13_sha256)支持它;COSE 注册了 ESB256。德国政府 PKI 和电子身份证件使用 Brainpool 曲线,NIST SP 800-186 也允许出于互操作性考虑使用它们。
各标准中的名称
| 标准 | 名称 |
|---|
| RFC 5639 | brainpoolP256r1 |
| IANA TLS 1.3 | brainpoolP256r1tls13 |
域参数
256 位素域 · 约 128 位安全强度
- 域素数 p
- 0xa9fb57dba1eea9bc3e660a909d838d726e3bf623d52620282013481d1f6e5377
- 系数 a
- 0x7d5a0975fc2c3057eef67530417affe7fb8055c126dc5c6ce94a4b44f330b5d9
- 系数 b
- 0x26dc5c6ce94a4b44f330b5d9bbd77cbf958416295cf7e1ce6bccdc18ff8c07b6
- 基点 x 坐标
- 0x8bd2aeb9cb7e57cb2c4b482ffc81b7afb9de27e1e3bd23c23a4453bd9ace3262
- 基点 y 坐标
- 0x547ef835c3dac4fd97f8461a14611dc9c27745132ded8e545c1d54c72f046997
- 基点的阶 n
- 0xa9fb57dba1eea9bc3e660a909d838d718c397aa3b561a6f7901e0e82974856a7
- 余因子 h
- 0x1
用于
- TLS 1.2 (RFC 7027)
- TLS 1.3 (RFC 8734)
- German eID and ePassports
- X.509 (BSI TR-03116)
← 全部曲线