Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

brainpoolP256r1

A brainpoolP256r1 é a curva Brainpool de 256 bits da RFC 5639, com parâmetros derivados de forma verificável dos dígitos de π e do número e.

brainpoolP256r1 é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 256 bits com um subgrupo de ordem prima de 256 bits e cofator 1; o nível de segurança estimado é de 128 bits. Status: segura, mas regional ou de nicho.

As curvas Brainpool (RFC 5639) foram geradas de forma pseudoaleatória verificável: os primos vêm dos dígitos de π e os coeficientes da curva, dos dígitos de e, de modo que qualquer pessoa pode recalculá-los (RFC 5639, apêndice A). A brainpoolP256r1 é a curva aleatória de 256 bits; ela tem ordem prima (cofator 1) e cerca de 128 bits de segurança.

O TLS oferece suporte a ela por meio da RFC 7027 (TLS 1.2) e da RFC 8734 (TLS 1.3, grupo brainpoolP256r1tls13 e esquema de assinatura ecdsa_brainpoolP256r1tls13_sha256); o COSE registra o ESB256. A PKI do governo alemão e os documentos de identidade eletrônicos usam as curvas Brainpool, e o NIST SP 800-186 as permite para fins de interoperabilidade.

Nomes nos padrões

PadrãoNome
RFC 5639brainpoolP256r1
IANA TLS 1.3brainpoolP256r1tls13

Identificadores de objeto

Parâmetros de domínio

campo primo de 256 bits · cerca de 128 bits de segurança

Primo p do campo
0xa9fb57dba1eea9bc3e660a909d838d726e3bf623d52620282013481d1f6e5377
Coeficiente a
0x7d5a0975fc2c3057eef67530417affe7fb8055c126dc5c6ce94a4b44f330b5d9
Coeficiente b
0x26dc5c6ce94a4b44f330b5d9bbd77cbf958416295cf7e1ce6bccdc18ff8c07b6
Coordenada x do ponto base
0x8bd2aeb9cb7e57cb2c4b482ffc81b7afb9de27e1e3bd23c23a4453bd9ace3262
Coordenada y do ponto base
0x547ef835c3dac4fd97f8461a14611dc9c27745132ded8e545c1d54c72f046997
Ordem n do ponto base
0xa9fb57dba1eea9bc3e660a909d838d718c397aa3b561a6f7901e0e82974856a7
Cofator h
0x1

Usada em

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identificadores em registros

Grupos suportados do TLS
brainpoolP256r1 0x001AbrainpoolP256r1tls13 0x001F
Esquemas de assinatura do TLS
ecdsa_brainpoolP256r1tls13_sha256 0x081A
Algoritmos COSE
ESB256 -265
Curvas elípticas COSE
brainpoolP256r1 256

Padrões e referências

Todas as curvas