本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

brainpoolP256r1

brainpoolP256r1 は RFC 5639 の 256 ビットの Brainpool 曲線で、パラメーターは π と e の数字列から検証可能な方法で導出されています。

brainpoolP256r1 は、256 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 256 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 128 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

Brainpool 曲線(RFC 5639)は、検証可能な擬似乱数的手法で生成されました。素数は π の数字列から、曲線の係数は e の数字列から得られているため、誰でも再計算できます(RFC 5639 付録 A)。brainpoolP256r1 は 256 ビットのランダム曲線で、位数は素数(コファクター 1)、セキュリティは約 128 ビットです。

TLS では RFC 7027(TLS 1.2)と RFC 8734(TLS 1.3、グループ brainpoolP256r1tls13 と署名方式 ecdsa_brainpoolP256r1tls13_sha256)によってサポートされており、COSE には ESB256 が登録されています。ドイツ政府の PKI と電子的な本人確認書類は Brainpool 曲線を使っており、NIST SP 800-186 も相互運用性のためにこれらの曲線の使用を認めています。

規格での名称

規格名称
RFC 5639brainpoolP256r1
IANA TLS 1.3brainpoolP256r1tls13

オブジェクト識別子

ドメインパラメーター

256 ビットの素体 · 約 128 ビットセキュリティ

有限体の素数 p
0xa9fb57dba1eea9bc3e660a909d838d726e3bf623d52620282013481d1f6e5377
係数 a
0x7d5a0975fc2c3057eef67530417affe7fb8055c126dc5c6ce94a4b44f330b5d9
係数 b
0x26dc5c6ce94a4b44f330b5d9bbd77cbf958416295cf7e1ce6bccdc18ff8c07b6
ベースポイントの x 座標
0x8bd2aeb9cb7e57cb2c4b482ffc81b7afb9de27e1e3bd23c23a4453bd9ace3262
ベースポイントの y 座標
0x547ef835c3dac4fd97f8461a14611dc9c27745132ded8e545c1d54c72f046997
ベースポイントの位数 n
0xa9fb57dba1eea9bc3e660a909d838d718c397aa3b561a6f7901e0e82974856a7
コファクター h
0x1

採用例

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

レジストリでの識別子

TLS のサポートされるグループ
brainpoolP256r1 0x001AbrainpoolP256r1tls13 0x001F
TLS の署名方式
ecdsa_brainpoolP256r1tls13_sha256 0x081A
COSE アルゴリズム
ESB256 -265
COSE の楕円曲線
brainpoolP256r1 256

規格と参考文献

すべての曲線