Saltar al contenido
ecdsa.com
AceptableWeierstrass corta

GC512C

GC512C (id-tc26-gost-3410-2012-512-paramSetC) es la curva GOST de 512 bits con forma de Edwards torcida.

GC512C es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 512 bits, con un subgrupo de orden primo de 510 bits y cofactor 4; su nivel de seguridad estimado es de 256 bits. Estado: segura, pero regional o de nicho.

Publicado junto con GC256A en el RFC 7836 §5.2, paramSetC tiene cofactor 4 y es birracionalmente equivalente a una curva de Edwards torcida, de modo que las implementaciones pueden usar fórmulas de suma completas. Comparte el primo 2^512 − 569 con GC512A.

TLS la incluye como grupo GC512C con el esquema de firma gostr34102012_512c (RFC 9189, RFC 9367).

Nombres en los estándares

EstándarNombre
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

Identificadores de objeto

Parámetros de dominio

campo primo de 512 bits · seguridad de unos 256 bits

Primo del campo p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
Coeficiente a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
Coeficiente b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
Punto base x
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
Punto base y
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
Orden n del punto base
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
Cofactor h
0x4

Se usa en

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identificadores en registros

Grupos admitidos de TLS
GC512C 0x0028
Esquemas de firma de TLS
gostr34102012_512c 0x070F

Estándares y referencias

Todas las curvas