Zum Inhalt springen
ecdsa.com
AkzeptabelKurze Weierstraß-Form

GC512C

GC512C (id-tc26-gost-3410-2012-512-paramSetC) ist die 512-Bit-GOST-Kurve in Twisted-Edwards-Form.

GC512C ist eine Kurve in kurzer Weierstraß-Form y² = x³ + ax + b über einem 512-Bit-Primkörper mit einer 510-Bit-Untergruppe von Primordnung und dem Kofaktor 4; das geschätzte Sicherheitsniveau beträgt 256 Bit. Status: sicher, aber nur regional oder in Nischen verbreitet.

paramSetC wurde zusammen mit GC256A in RFC 7836 §5.2 veröffentlicht, hat den Kofaktor 4 und ist birational äquivalent zu einer Twisted-Edwards-Kurve; Implementierungen können daher vollständige Additionsformeln verwenden. Die Kurve teilt sich die Primzahl 2^512 − 569 mit GC512A.

TLS führt sie als Gruppe GC512C mit dem Signaturverfahren gostr34102012_512c (RFC 9189, RFC 9367).

Namen in Standards

StandardName
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

Object Identifier

Domainparameter

512-Bit-Primkörper · etwa 256-Bit-Sicherheit

Primzahl p des Körpers
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
Koeffizient a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
Koeffizient b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
x-Koordinate des Basispunkts
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
y-Koordinate des Basispunkts
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
Ordnung n des Basispunkts
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
Kofaktor h
0x4

Verwendet in

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Kennungen in Registern

TLS-Supported-Groups
GC512C 0x0028
TLS-Signaturverfahren
gostr34102012_512c 0x070F

Standards und Quellen

Alle Kurven