Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

GC512C

A GC512C (id-tc26-gost-3410-2012-512-paramSetC) é a curva GOST de 512 bits com forma de Edwards torcida.

GC512C é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 512 bits com um subgrupo de ordem prima de 510 bits e cofator 4; o nível de segurança estimado é de 256 bits. Status: segura, mas regional ou de nicho.

Publicado junto com a GC256A na RFC 7836 §5.2, o paramSetC tem cofator 4 e é birracionalmente equivalente a uma curva de Edwards torcida, de modo que as implementações podem usar fórmulas de adição completas. Ele compartilha o primo 2^512 − 569 com a GC512A.

O TLS a lista como grupo GC512C, com o esquema de assinatura gostr34102012_512c (RFC 9189, RFC 9367).

Nomes nos padrões

PadrãoNome
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

Identificadores de objeto

Parâmetros de domínio

campo primo de 512 bits · cerca de 256 bits de segurança

Primo p do campo
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
Coeficiente a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
Coeficiente b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
Coordenada x do ponto base
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
Coordenada y do ponto base
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
Ordem n do ponto base
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
Cofator h
0x4

Usada em

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identificadores em registros

Grupos suportados do TLS
GC512C 0x0028
Esquemas de assinatura do TLS
gostr34102012_512c 0x070F

Padrões e referências

Todas as curvas