本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

GC512C

GC512C(id-tc26-gost-3410-2012-512-paramSetC)は、ツイストエドワーズ形式を持つ 512 ビットの GOST 曲線です。

GC512C は、512 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 510 ビットの素数である部分群とコファクター 4 を持ちます。推定セキュリティレベルは 256 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

RFC 7836 §5.2 で GC256A とともに公開された paramSetC はコファクターが 4 で、ツイストエドワーズ曲線と双有理同値であるため、実装では完全な加算公式を使えます。素数 2^512 − 569 は GC512A と共通です。

TLS ではグループ GC512C、署名方式 gostr34102012_512c として登録されています(RFC 9189、RFC 9367)。

規格での名称

規格名称
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

オブジェクト識別子

ドメインパラメーター

512 ビットの素体 · 約 256 ビットセキュリティ

有限体の素数 p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
係数 a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
係数 b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
ベースポイントの x 座標
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
ベースポイントの y 座標
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
ベースポイントの位数 n
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
コファクター h
0x4

採用例

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

レジストリでの識別子

TLS のサポートされるグループ
GC512C 0x0028
TLS の署名方式
gostr34102012_512c 0x070F

規格と参考文献

すべての曲線