GC512A は、512 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 512 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 256 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。
GOST R 34.10-2012 では 512 ビットの署名鍵が追加されました。RFC 7836 §5.1.1 で公開された paramSetA は、素数 2^512 − 569 上の曲線 y² = x³ − 3x + b で、位数は素数であり、約 256 ビットのセキュリティを提供します。
署名には 512 ビットの Streebog ハッシュを使います。TLS ではこの曲線がグループ GC512A、署名方式 gostr34102012_512a として登録されています(RFC 9189、RFC 9367)。
規格での名称
| 規格 | 名称 |
|---|
| IANA TLS (RFC 9189) | GC512A |
| TC 26 | id-tc26-gost-3410-12-512-paramSetA |
ドメインパラメーター
512 ビットの素体 · 約 256 ビットセキュリティ
- 有限体の素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
- 係数 a
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc4
- 係数 b
- 0xe8c2505dedfc86ddc1bd0b2b6667f1da34b82574761cb0e879bd081cfd0b6265ee3cb090f30d27614cb4574010da90dd862ef9d4ebee4761503190785a71c760
- ベースポイントの x 座標
- 0x3
- ベースポイントの y 座標
- 0x7503cfe87a836ae3a61b8816e25450e6ce5e1c93acf1abc1778064fdcbefa921df1626be4fd036e93d75e6a50e3a41e98028fe5fc235f5b889a589cb5215f2a4
- ベースポイントの位数 n
- 0xffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff27e69532f48d89116ff22b8d4e0560609b4b38abfad2b85dcacdb1411f10b275
- コファクター h
- 0x1
採用例
- GOST R 34.10-2012 signatures
- TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
- Russian government PKI
← すべての曲線