跳到主要内容
ecdsa.com
可接受短 Weierstrass 形式

GC512A

GC512A(id-tc26-gost-3410-12-512-paramSetA)是 GOST R 34.10-2012 中的一条 512 位曲线。

GC512A 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 512 位素域上,其素数阶子群为 512 位,余因子为 1;估计安全级别为 256 位。状态:安全,但仅限特定地区或小众场景。

GOST R 34.10-2012 新增了 512 位签名密钥。paramSetA 发布于 RFC 7836 §5.1.1,是素数 2^512 − 569 上的曲线 y² = x³ − 3x + b,阶为素数,安全强度约为 256 位。

签名使用 512 位 Streebog 哈希;TLS 将这条曲线列为组 GC512A,对应的签名方案为 gostr34102012_512a(RFC 9189、RFC 9367)。

各标准中的名称

标准名称
IANA TLS (RFC 9189)GC512A
TC 26id-tc26-gost-3410-12-512-paramSetA

对象标识符

域参数

512 位素域 · 约 256 位安全强度

域素数 p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
系数 a
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc4
系数 b
0xe8c2505dedfc86ddc1bd0b2b6667f1da34b82574761cb0e879bd081cfd0b6265ee3cb090f30d27614cb4574010da90dd862ef9d4ebee4761503190785a71c760
基点 x 坐标
0x3
基点 y 坐标
0x7503cfe87a836ae3a61b8816e25450e6ce5e1c93acf1abc1778064fdcbefa921df1626be4fd036e93d75e6a50e3a41e98028fe5fc235f5b889a589cb5215f2a4
基点的阶 n
0xffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff27e69532f48d89116ff22b8d4e0560609b4b38abfad2b85dcacdb1411f10b275
余因子 h
0x1

用于

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

注册表中的标识符

TLS 支持的组
GC512A 0x0026
TLS 签名方案
gostr34102012_512a 0x070D

标准与参考资料

全部曲线