A GC512A (id-tc26-gost-3410-12-512-paramSetA) é uma curva de 512 bits do GOST R 34.10-2012.
GC512A é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 512 bits com um subgrupo de ordem prima de 512 bits e cofator 1; o nível de segurança estimado é de 256 bits. Status: segura, mas regional ou de nicho.
O GOST R 34.10-2012 acrescentou chaves de assinatura de 512 bits. O paramSetA, publicado na RFC 7836 §5.1.1, é y² = x³ − 3x + b sobre o primo 2^512 − 569 e tem ordem prima, o que dá cerca de 256 bits de segurança.
As assinaturas usam o hash Streebog de 512 bits; o TLS lista a curva como grupo GC512A, com o esquema de assinatura gostr34102012_512a (RFC 9189, RFC 9367).