GC512A (id-tc26-gost-3410-12-512-paramSetA) es una curva de 512 bits de GOST R 34.10-2012.
GC512A es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 512 bits, con un subgrupo de orden primo de 512 bits y cofactor 1; su nivel de seguridad estimado es de 256 bits. Estado: segura, pero regional o de nicho.
GOST R 34.10-2012 añadió claves de firma de 512 bits. paramSetA, publicado en el RFC 7836 §5.1.1, es y² = x³ − 3x + b sobre el primo 2^512 − 569 y tiene orden primo, lo que da unos 256 bits de seguridad.
Las firmas usan el hash Streebog de 512 bits; TLS incluye la curva como grupo GC512A con el esquema de firma gostr34102012_512a (RFC 9189, RFC 9367).