GC512A (id-tc26-gost-3410-12-512-paramSetA) est une courbe de 512 bits de la norme GOST R 34.10-2012.
GC512A est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 512 bits, avec un sous-groupe d’ordre premier de 512 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 256 bits. Statut : sûre, mais régionale ou de niche.
GOST R 34.10-2012 a ajouté des clés de signature de 512 bits. Le jeu de paramètres paramSetA, publié dans la RFC 7836, §5.1.1, définit la courbe d’ordre premier y² = x³ − 3x + b modulo le nombre premier 2^512 − 569 ; elle offre environ 256 bits de sécurité.
Les signatures utilisent la fonction de hachage Streebog de 512 bits ; TLS répertorie la courbe comme groupe GC512A, avec le schéma de signature gostr34102012_512a (RFC 9189, RFC 9367).