Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

GC512C

GC512C (id-tc26-gost-3410-2012-512-paramSetC) est la courbe GOST de 512 bits dotée d’une forme d’Edwards tordue.

GC512C est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 512 bits, avec un sous-groupe d’ordre premier de 510 bits et un cofacteur de 4 ; son niveau de sécurité estimé est de 256 bits. Statut : sûre, mais régionale ou de niche.

Publiée avec GC256A dans la RFC 7836, §5.2, la courbe paramSetC a pour cofacteur 4 et est birationnellement équivalente à une courbe d’Edwards tordue, si bien que les implémentations peuvent utiliser des formules d’addition complètes. Elle partage le nombre premier 2^512 − 569 avec GC512A.

TLS la répertorie comme groupe GC512C, avec le schéma de signature gostr34102012_512c (RFC 9189, RFC 9367).

Noms dans les normes

NormeNom
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

Identifiants d’objet

Paramètres de domaine

corps premier de 512 bits · sécurité d’environ 256 bits

Nombre premier p du corps
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
Coefficient a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
Coefficient b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
Coordonnée x du point de base
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
Coordonnée y du point de base
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
Ordre n du point de base
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
Cofacteur h
0x4

Utilisée dans

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identifiants dans les registres

Groupes pris en charge par TLS
GC512C 0x0028
Schémas de signature TLS
gostr34102012_512c 0x070F

Normes et références

Toutes les courbes