跳到主要内容
ecdsa.com
可接受短 Weierstrass 形式

GC512C

GC512C(id-tc26-gost-3410-2012-512-paramSetC)是具有扭曲 Edwards 形式的 512 位 GOST 曲线。

GC512C 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 512 位素域上,其素数阶子群为 510 位,余因子为 4;估计安全级别为 256 位。状态:安全,但仅限特定地区或小众场景。

paramSetC 与 GC256A 一同发布于 RFC 7836 §5.2,余因子为 4,与扭曲 Edwards 曲线双有理等价,因此实现可以使用完备加法公式。它与 GC512A 共用素数 2^512 − 569。

TLS 将其列为组 GC512C,对应的签名方案为 gostr34102012_512c(RFC 9189、RFC 9367)。

各标准中的名称

标准名称
IANA TLS (RFC 9189)GC512C
TC 26id-tc26-gost-3410-2012-512-paramSetC

对象标识符

域参数

512 位素域 · 约 256 位安全强度

域素数 p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffdc7
系数 a
0xdc9203e514a721875485a529d2c722fb187bc8980eb866644de41c68e143064546e861c0e2c9edd92ade71f46fcf50ff2ad97f951fda9f2a2eb6546f39689bd3
系数 b
0xb4c4ee28cebc6c2c8ac12952cf37f16ac7efb6a9f69f4b57ffda2e4f0de5ade038cbc2fff719d2c18de0284b8bfef3b52b8cc7a5f5bf0a3c8d2319a5312557e1
基点 x 坐标
0xe2e31edfc23de7bdebe241ce593ef5de2295b7a9cbaef021d385f7074cea043aa27272a7ae602bf2a7b9033db9ed3610c6fb85487eae97aac5bc7928c1950148
基点 y 坐标
0xf5ce40d95b5eb899abbccff5911cb8577939804d6527378b8c108c3d2090ff9be18e2d33e3021ed2ef32d85822423b6304f726aa854bae07d0396e9a9addc40f
基点的阶 n
0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffc98cdba46506ab004c33a9ff5147502cc8eda9e7a769a12694623cef47f023ed
余因子 h
0x4

用于

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

注册表中的标识符

TLS 支持的组
GC512C 0x0028
TLS 签名方案
gostr34102012_512c 0x070F

标准与参考资料

全部曲线