GC256C es la curva GOST de 256 bits CryptoPro-B (id-GostR3410-2001-CryptoPro-B-ParamSet).
GC256C es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 256 bits, con un subgrupo de orden primo de 256 bits y cofactor 1; su nivel de seguridad estimado es de 128 bits. Estado: segura, pero regional o de nicho.
GC256C se definió para GOST R 34.10-2001 en el RFC 4357 §11.4, y GOST R 34.10-2012 la conserva como paramSetC (RFC 9215). Es y² = x³ − 3x + b sobre el primo 2^255 + 3225, con orden primo.
TLS la incluye como grupo GC256C con el esquema de firma gostr34102012_256c (RFC 9189, RFC 9367).