GC256C — 256-битная кривая GOST под названием CryptoPro-B (id-GostR3410-2001-CryptoPro-B-ParamSet).
GC256C — кривая в короткой форме Вейерштрасса y² = x³ + ax + b над 256-битным простым полем с 256-битной подгруппой простого порядка и кофактором 1; оценочный уровень стойкости — 128 бит. Статус: безопасна, но региональная или нишевая.
GC256C определена для GOST R 34.10-2001 в RFC 4357, § 11.4, а GOST R 34.10-2012 сохраняет её как paramSetC (RFC 9215). Это кривая y² = x³ − 3x + b простого порядка над полем по модулю простого числа 2^255 + 3225.
В TLS она значится как группа GC256C со схемой подписи gostr34102012_256c (RFC 9189, RFC 9367).