Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

GC256C

GC256C est la courbe GOST de 256 bits CryptoPro-B (id-GostR3410-2001-CryptoPro-B-ParamSet).

GC256C est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 256 bits, avec un sous-groupe d’ordre premier de 256 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 128 bits. Statut : sûre, mais régionale ou de niche.

GC256C a été définie pour GOST R 34.10-2001 dans la RFC 4357, §11.4, et GOST R 34.10-2012 la conserve sous le nom paramSetC (RFC 9215). C’est la courbe d’ordre premier y² = x³ − 3x + b définie modulo le nombre premier 2^255 + 3225.

TLS la répertorie comme groupe GC256C, avec le schéma de signature gostr34102012_256c (RFC 9189, RFC 9367).

Noms dans les normes

NormeNom
IANA TLS (RFC 9189)GC256C
TC 26id-tc26-gost-3410-2012-256-paramSetC
RFC 4357id-GostR3410-2001-CryptoPro-B-ParamSet

Identifiants d’objet

Paramètres de domaine

corps premier de 256 bits · sécurité d’environ 128 bits

Nombre premier p du corps
0x8000000000000000000000000000000000000000000000000000000000000c99
Coefficient a
0x8000000000000000000000000000000000000000000000000000000000000c96
Coefficient b
0x3e1af419a269a5f866a7d3c25c3df80ae979259373ff2b182f49d4ce7e1bbc8b
Coordonnée x du point de base
0x1
Coordonnée y du point de base
0x3fa8124359f96680b83d1c3eb2c070e5c545c9858d03ecfb744bf8d717717efc
Ordre n du point de base
0x800000000000000000000000000000015f700cfff1a624e5e497161bcc8a198f
Cofacteur h
0x1

Utilisée dans

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identifiants dans les registres

Groupes pris en charge par TLS
GC256C 0x0024
Schémas de signature TLS
gostr34102012_256c 0x070B

Normes et références

Toutes les courbes