Zum Inhalt springen
ecdsa.com
AkzeptabelKurze Weierstraß-Form

GC256C

GC256C ist die 256-Bit-GOST-Kurve CryptoPro-B (id-GostR3410-2001-CryptoPro-B-ParamSet).

GC256C ist eine Kurve in kurzer Weierstraß-Form y² = x³ + ax + b über einem 256-Bit-Primkörper mit einer 256-Bit-Untergruppe von Primordnung und dem Kofaktor 1; das geschätzte Sicherheitsniveau beträgt 128 Bit. Status: sicher, aber nur regional oder in Nischen verbreitet.

GC256C wurde für GOST R 34.10-2001 in RFC 4357 §11.4 definiert, und GOST R 34.10-2012 übernimmt sie als paramSetC (RFC 9215). Die Kurve ist y² = x³ − 3x + b über der Primzahl 2^255 + 3225 und hat Primordnung.

TLS führt sie als Gruppe GC256C mit dem Signaturverfahren gostr34102012_256c (RFC 9189, RFC 9367).

Namen in Standards

StandardName
IANA TLS (RFC 9189)GC256C
TC 26id-tc26-gost-3410-2012-256-paramSetC
RFC 4357id-GostR3410-2001-CryptoPro-B-ParamSet

Object Identifier

Domainparameter

256-Bit-Primkörper · etwa 128-Bit-Sicherheit

Primzahl p des Körpers
0x8000000000000000000000000000000000000000000000000000000000000c99
Koeffizient a
0x8000000000000000000000000000000000000000000000000000000000000c96
Koeffizient b
0x3e1af419a269a5f866a7d3c25c3df80ae979259373ff2b182f49d4ce7e1bbc8b
x-Koordinate des Basispunkts
0x1
y-Koordinate des Basispunkts
0x3fa8124359f96680b83d1c3eb2c070e5c545c9858d03ecfb744bf8d717717efc
Ordnung n des Basispunkts
0x800000000000000000000000000000015f700cfff1a624e5e497161bcc8a198f
Kofaktor h
0x1

Verwendet in

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Kennungen in Registern

TLS-Supported-Groups
GC256C 0x0024
TLS-Signaturverfahren
gostr34102012_256c 0x070B

Standards und Quellen

Alle Kurven