跳到主要内容
ecdsa.com
可接受短 Weierstrass 形式

GC256C

GC256C 即 256 位 GOST 曲线 CryptoPro-B(id-GostR3410-2001-CryptoPro-B-ParamSet)。

GC256C 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 256 位素域上,其素数阶子群为 256 位,余因子为 1;估计安全级别为 128 位。状态:安全,但仅限特定地区或小众场景。

GC256C 在 RFC 4357 §11.4 中为 GOST R 34.10-2001 而定义,GOST R 34.10-2012 将其保留为 paramSetC(RFC 9215)。它是素数 2^255 + 3225 上的曲线 y² = x³ − 3x + b,阶为素数。

TLS 将其列为组 GC256C,对应的签名方案为 gostr34102012_256c(RFC 9189、RFC 9367)。

各标准中的名称

标准名称
IANA TLS (RFC 9189)GC256C
TC 26id-tc26-gost-3410-2012-256-paramSetC
RFC 4357id-GostR3410-2001-CryptoPro-B-ParamSet

对象标识符

域参数

256 位素域 · 约 128 位安全强度

域素数 p
0x8000000000000000000000000000000000000000000000000000000000000c99
系数 a
0x8000000000000000000000000000000000000000000000000000000000000c96
系数 b
0x3e1af419a269a5f866a7d3c25c3df80ae979259373ff2b182f49d4ce7e1bbc8b
基点 x 坐标
0x1
基点 y 坐标
0x3fa8124359f96680b83d1c3eb2c070e5c545c9858d03ecfb744bf8d717717efc
基点的阶 n
0x800000000000000000000000000000015f700cfff1a624e5e497161bcc8a198f
余因子 h
0x1

用于

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

注册表中的标识符

TLS 支持的组
GC256C 0x0024
TLS 签名方案
gostr34102012_256c 0x070B

标准与参考资料

全部曲线