A GC256C é a curva GOST de 256 bits CryptoPro-B (id-GostR3410-2001-CryptoPro-B-ParamSet).
GC256C é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 256 bits com um subgrupo de ordem prima de 256 bits e cofator 1; o nível de segurança estimado é de 128 bits. Status: segura, mas regional ou de nicho.
A GC256C foi definida para o GOST R 34.10-2001 na RFC 4357 §11.4, e o GOST R 34.10-2012 a mantém como paramSetC (RFC 9215). Ela é y² = x³ − 3x + b sobre o primo 2^255 + 3225, com ordem prima.
O TLS a lista como grupo GC256C, com o esquema de assinatura gostr34102012_256c (RFC 9189, RFC 9367).