GC256C は RFC 4357 §11.4 で GOST R 34.10-2001 向けに定義され、GOST R 34.10-2012 でも paramSetC として引き継がれています(RFC 9215)。素数 2^255 + 3225 上の曲線 y² = x³ − 3x + b で、位数は素数です。
TLS ではグループ GC256C、署名方式 gostr34102012_256c として登録されています(RFC 9189、RFC 9367)。
GC256C は、256 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 256 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 128 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。
GC256C は RFC 4357 §11.4 で GOST R 34.10-2001 向けに定義され、GOST R 34.10-2012 でも paramSetC として引き継がれています(RFC 9215)。素数 2^255 + 3225 上の曲線 y² = x³ − 3x + b で、位数は素数です。
TLS ではグループ GC256C、署名方式 gostr34102012_256c として登録されています(RFC 9189、RFC 9367)。
| 規格 | 名称 |
|---|---|
| IANA TLS (RFC 9189) | GC256C |
| TC 26 | id-tc26-gost-3410-2012-256-paramSetC |
| RFC 4357 | id-GostR3410-2001-CryptoPro-B-ParamSet |
256 ビットの素体 · 約 128 ビットセキュリティ