Saltar al contenido
ecdsa.com
AceptableWeierstrass corta

GC512B

GC512B (id-tc26-gost-3410-12-512-paramSetB) es una curva de 512 bits de GOST R 34.10-2012.

GC512B es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 512 bits, con un subgrupo de orden primo de 512 bits y cofactor 1; su nivel de seguridad estimado es de 256 bits. Estado: segura, pero regional o de nicho.

paramSetB, publicado junto con paramSetA en el RFC 7836 §5.1.1, es y² = x³ − 3x + b sobre el primo 2^511 + 111 y tiene orden primo.

TLS la incluye como grupo GC512B con el esquema de firma gostr34102012_512b (RFC 9189, RFC 9367).

Nombres en los estándares

EstándarNombre
IANA TLS (RFC 9189)GC512B
TC 26id-tc26-gost-3410-12-512-paramSetB

Identificadores de objeto

Parámetros de dominio

campo primo de 512 bits · seguridad de unos 256 bits

Primo del campo p
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006f
Coeficiente a
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006c
Coeficiente b
0x687d1b459dc841457e3e06cf6f5e2517b97c7d614af138bcbf85dc806c4b289f3e965d2db1416d217f8b276fad1ab69c50f78bee1fa3106efb8ccbc7c5140116
Punto base x
0x2
Punto base y
0x1a8f7eda389b094c2c071e3647a8940f3c123b697578c213be6dd9e6c8ec7335dcb228fd1edf4a39152cbcaaf8c0398828041055f94ceeec7e21340780fe41bd
Orden n del punto base
0x800000000000000000000000000000000000000000000000000000000000000149a1ec142565a545acfdb77bd9d40cfa8b996712101bea0ec6346c54374f25bd
Cofactor h
0x1

Se usa en

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identificadores en registros

Grupos admitidos de TLS
GC512B 0x0027
Esquemas de firma de TLS
gostr34102012_512b 0x070E

Estándares y referencias

Todas las curvas