GC512B (id-tc26-gost-3410-12-512-paramSetB) est une courbe de 512 bits de la norme GOST R 34.10-2012.
GC512B est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 512 bits, avec un sous-groupe d’ordre premier de 512 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 256 bits. Statut : sûre, mais régionale ou de niche.
Le jeu de paramètres paramSetB, publié avec paramSetA dans la RFC 7836, §5.1.1, définit la courbe d’ordre premier y² = x³ − 3x + b modulo le nombre premier 2^511 + 111.
TLS la répertorie comme groupe GC512B, avec le schéma de signature gostr34102012_512b (RFC 9189, RFC 9367).