跳到主要内容
ecdsa.com
可接受短 Weierstrass 形式

GC512B

GC512B(id-tc26-gost-3410-12-512-paramSetB)是 GOST R 34.10-2012 中的一条 512 位曲线。

GC512B 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 512 位素域上,其素数阶子群为 512 位,余因子为 1;估计安全级别为 256 位。状态:安全,但仅限特定地区或小众场景。

paramSetB 与 paramSetA 一同发布于 RFC 7836 §5.1.1,是素数 2^511 + 111 上的曲线 y² = x³ − 3x + b,阶为素数。

TLS 将其列为组 GC512B,对应的签名方案为 gostr34102012_512b(RFC 9189、RFC 9367)。

各标准中的名称

标准名称
IANA TLS (RFC 9189)GC512B
TC 26id-tc26-gost-3410-12-512-paramSetB

对象标识符

域参数

512 位素域 · 约 256 位安全强度

域素数 p
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006f
系数 a
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006c
系数 b
0x687d1b459dc841457e3e06cf6f5e2517b97c7d614af138bcbf85dc806c4b289f3e965d2db1416d217f8b276fad1ab69c50f78bee1fa3106efb8ccbc7c5140116
基点 x 坐标
0x2
基点 y 坐标
0x1a8f7eda389b094c2c071e3647a8940f3c123b697578c213be6dd9e6c8ec7335dcb228fd1edf4a39152cbcaaf8c0398828041055f94ceeec7e21340780fe41bd
基点的阶 n
0x800000000000000000000000000000000000000000000000000000000000000149a1ec142565a545acfdb77bd9d40cfa8b996712101bea0ec6346c54374f25bd
余因子 h
0x1

用于

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

注册表中的标识符

TLS 支持的组
GC512B 0x0027
TLS 签名方案
gostr34102012_512b 0x070E

标准与参考资料

全部曲线