A GC512B (id-tc26-gost-3410-12-512-paramSetB) é uma curva de 512 bits do GOST R 34.10-2012.
GC512B é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 512 bits com um subgrupo de ordem prima de 512 bits e cofator 1; o nível de segurança estimado é de 256 bits. Status: segura, mas regional ou de nicho.
O paramSetB, publicado junto com o paramSetA na RFC 7836 §5.1.1, é y² = x³ − 3x + b sobre o primo 2^511 + 111 e tem ordem prima.
O TLS a lista como grupo GC512B, com o esquema de assinatura gostr34102012_512b (RFC 9189, RFC 9367).