本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

GC512B

GC512B(id-tc26-gost-3410-12-512-paramSetB)は、GOST R 34.10-2012 の 512 ビット曲線の 1 つです。

GC512B は、512 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 512 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 256 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

RFC 7836 §5.1.1 で paramSetA とともに公開された paramSetB は、素数 2^511 + 111 上の曲線 y² = x³ − 3x + b で、位数は素数です。

TLS ではグループ GC512B、署名方式 gostr34102012_512b として登録されています(RFC 9189、RFC 9367)。

規格での名称

規格名称
IANA TLS (RFC 9189)GC512B
TC 26id-tc26-gost-3410-12-512-paramSetB

オブジェクト識別子

ドメインパラメーター

512 ビットの素体 · 約 256 ビットセキュリティ

有限体の素数 p
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006f
係数 a
0x8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000006c
係数 b
0x687d1b459dc841457e3e06cf6f5e2517b97c7d614af138bcbf85dc806c4b289f3e965d2db1416d217f8b276fad1ab69c50f78bee1fa3106efb8ccbc7c5140116
ベースポイントの x 座標
0x2
ベースポイントの y 座標
0x1a8f7eda389b094c2c071e3647a8940f3c123b697578c213be6dd9e6c8ec7335dcb228fd1edf4a39152cbcaaf8c0398828041055f94ceeec7e21340780fe41bd
ベースポイントの位数 n
0x800000000000000000000000000000000000000000000000000000000000000149a1ec142565a545acfdb77bd9d40cfa8b996712101bea0ec6346c54374f25bd
コファクター h
0x1

採用例

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

レジストリでの識別子

TLS のサポートされるグループ
GC512B 0x0027
TLS の署名方式
gostr34102012_512b 0x070E

規格と参考文献

すべての曲線