GC256A (id-tc26-gost-3410-2012-256-paramSetA) es la curva GOST R 34.10-2012 de 256 bits con forma de Edwards torcida.
GC256A es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 256 bits, con un subgrupo de orden primo de 255 bits y cofactor 4; su nivel de seguridad estimado es de 128 bits. Estado: segura, pero regional o de nicho.
El estándar de firma ruso GOST R 34.10-2012 usa curvas que mantiene el comité de normalización TC 26. paramSetA, para claves de 256 bits y publicado en el RFC 7836 §5.2, tiene cofactor 4 y se eligió para que fuera birracionalmente equivalente a una curva de Edwards torcida, de modo que las implementaciones pueden usar fórmulas de suma completas.
Es la curva del algoritmo 23 de DNSSEC (RFC 9558) y aparece en TLS como grupo GC256A con el esquema de firma gostr34102012_256a (RFC 9189 para TLS 1.2, RFC 9367 para TLS 1.3). Las firmas la combinan con el hash Streebog de 256 bits (GOST R 34.11-2012).