本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

GC256A

GC256A(id-tc26-gost-3410-2012-256-paramSetA)は、ツイストエドワーズ形式を持つ 256 ビットの GOST R 34.10-2012 曲線です。

GC256A は、256 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 255 ビットの素数である部分群とコファクター 4 を持ちます。推定セキュリティレベルは 128 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

ロシアの署名規格 GOST R 34.10-2012 では、標準化技術委員会 TC 26 が管理する曲線を使います。RFC 7836 §5.2 で公開された 256 ビット鍵用の paramSetA はコファクターが 4 で、ツイストエドワーズ曲線と双有理同値になるように選ばれているため、実装では完全な加算公式を使えます。

DNSSEC のアルゴリズム 23(RFC 9558)の曲線であり、TLS ではグループ GC256A、署名方式 gostr34102012_256a として使われます(TLS 1.2 は RFC 9189、TLS 1.3 は RFC 9367)。署名では 256 ビットの Streebog ハッシュ(GOST R 34.11-2012)と組み合わせます。

規格での名称

規格名称
IANA TLS (RFC 9189)GC256A
TC 26id-tc26-gost-3410-2012-256-paramSetA

オブジェクト識別子

ドメインパラメーター

256 ビットの素体 · 約 128 ビットセキュリティ

有限体の素数 p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
係数 a
0xc2173f1513981673af4892c23035a27ce25e2013bf95aa33b22c656f277e7335
係数 b
0x295f9bae7428ed9ccc20e7c359a9d41a22fccd9108e17bf7ba9337a6f8ae9513
ベースポイントの x 座標
0x91e38443a5e82c0d880923425712b2bb658b9196932e02c78b2582fe742daa28
ベースポイントの y 座標
0x32879423ab1a0375895786c4bb46e9565fde0b5344766740af268adb32322e5c
ベースポイントの位数 n
0x400000000000000000000000000000000fd8cddfc87b6635c115af556c360c67
コファクター h
0x4

採用例

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • DNSSEC (algorithm 23)

レジストリでの識別子

TLS のサポートされるグループ
GC256A 0x0022
TLS の署名方式
gostr34102012_256a 0x0709
DNSSEC のアルゴリズム番号
ECC-GOST12 23

規格と参考文献

すべての曲線