GC256A 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 256 位素域上,其素数阶子群为 255 位,余因子为 4;估计安全级别为 128 位。状态:安全,但仅限特定地区或小众场景。
俄罗斯的 GOST R 34.10-2012 签名标准使用由 TC 26 标准化技术委员会维护的曲线。用于 256 位密钥的 paramSetA 发布于 RFC 7836 §5.2,余因子为 4,并经特意选取,使其与扭曲 Edwards 曲线双有理等价,因此实现可以使用完备加法公式。
它是 DNSSEC 算法 23(RFC 9558)所用的曲线,在 TLS 中作为组 GC256A 出现,对应的签名方案为 gostr34102012_256a(TLS 1.2 见 RFC 9189,TLS 1.3 见 RFC 9367)。签名时它与 256 位 Streebog 哈希(GOST R 34.11-2012)搭配使用。
各标准中的名称
| 标准 | 名称 |
|---|
| IANA TLS (RFC 9189) | GC256A |
| TC 26 | id-tc26-gost-3410-2012-256-paramSetA |
域参数
256 位素域 · 约 128 位安全强度
- 域素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
- 系数 a
- 0xc2173f1513981673af4892c23035a27ce25e2013bf95aa33b22c656f277e7335
- 系数 b
- 0x295f9bae7428ed9ccc20e7c359a9d41a22fccd9108e17bf7ba9337a6f8ae9513
- 基点 x 坐标
- 0x91e38443a5e82c0d880923425712b2bb658b9196932e02c78b2582fe742daa28
- 基点 y 坐标
- 0x32879423ab1a0375895786c4bb46e9565fde0b5344766740af268adb32322e5c
- 基点的阶 n
- 0x400000000000000000000000000000000fd8cddfc87b6635c115af556c360c67
- 余因子 h
- 0x4
用于
- GOST R 34.10-2012 signatures
- TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
- DNSSEC (algorithm 23)
← 全部曲线