Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

GC256A

A GC256A (id-tc26-gost-3410-2012-256-paramSetA) é a curva GOST R 34.10-2012 de 256 bits com forma de Edwards torcida.

GC256A é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 256 bits com um subgrupo de ordem prima de 255 bits e cofator 4; o nível de segurança estimado é de 128 bits. Status: segura, mas regional ou de nicho.

O padrão russo de assinatura GOST R 34.10-2012 usa curvas mantidas pelo comitê de padronização TC 26. O paramSetA para chaves de 256 bits, publicado na RFC 7836 §5.2, tem cofator 4 e foi escolhido para ser birracionalmente equivalente a uma curva de Edwards torcida, de modo que as implementações podem usar fórmulas de adição completas.

Ela é a curva do algoritmo 23 do DNSSEC (RFC 9558) e aparece no TLS como grupo GC256A, com o esquema de assinatura gostr34102012_256a (RFC 9189 para o TLS 1.2, RFC 9367 para o TLS 1.3). As assinaturas com essa curva usam o hash Streebog de 256 bits (GOST R 34.11-2012).

Nomes nos padrões

PadrãoNome
IANA TLS (RFC 9189)GC256A
TC 26id-tc26-gost-3410-2012-256-paramSetA

Identificadores de objeto

Parâmetros de domínio

campo primo de 256 bits · cerca de 128 bits de segurança

Primo p do campo
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
Coeficiente a
0xc2173f1513981673af4892c23035a27ce25e2013bf95aa33b22c656f277e7335
Coeficiente b
0x295f9bae7428ed9ccc20e7c359a9d41a22fccd9108e17bf7ba9337a6f8ae9513
Coordenada x do ponto base
0x91e38443a5e82c0d880923425712b2bb658b9196932e02c78b2582fe742daa28
Coordenada y do ponto base
0x32879423ab1a0375895786c4bb46e9565fde0b5344766740af268adb32322e5c
Ordem n do ponto base
0x400000000000000000000000000000000fd8cddfc87b6635c115af556c360c67
Cofator h
0x4

Usada em

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • DNSSEC (algorithm 23)

Identificadores em registros

Grupos suportados do TLS
GC256A 0x0022
Esquemas de assinatura do TLS
gostr34102012_256a 0x0709
Números de algoritmo DNSSEC
ECC-GOST12 23

Padrões e referências

Todas as curvas