本文へスキップ
ecdsa.com
DNSSEC と DANE

DANE TLSA のフィールド|用途、セレクター、マッチングタイプ

DANE の TLSA レコードの 3 つの数値フィールド(証明書の用途、セレクター、マッチングタイプ)の値を、略称と意味とともに IANA の DANE レジストリから掲載しています。

13 件中 13 件を表示

DANE TLSA の証明書の用途 · 5 件

TLSA レコードの 1 番目のフィールドです。

値略称説明参考文献
0注記PKIX-TAPKIX-TA(0)は TLSA の証明書の用途「CA constraint」です。RFC 6698
1PKIX-EEPKIX-EE(1)は TLSA の証明書の用途「Service certificate constraint」です。RFC 6698
2注記DANE-TADANE-TA(2)は TLSA の証明書の用途「Trust anchor assertion」です。RFC 6698
3注記DANE-EEDANE-EE(3)は TLSA の証明書の用途「Domain-issued certificate」です。RFC 6698
255PrivCertPrivCert(255)は TLSA の証明書の用途「Reserved for Private Use」です。RFC 6698
未割り当ての範囲と予約済みの範囲 · 1 件
範囲ステータス説明
4–254unassignedUnassigned

出典:DNS-Based Authentication of Named Entities (DANE) Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 TLSA Certificate Usages

注目すべき項目の注記

pkix-ta

PKIX-TA(0)は、公開 CA までのチェーンがあり、かつその CA が TLSA レコードと一致することを求めます。RFC 7672 は SMTP での使用を推奨していません。

用途 0 と 1 は、通常の Web PKI の検証に DNS による制約を加えます。メールサーバー間の SMTP について、RFC 7672 §3.1.3 は TLSA レコードでこれらを使うべきではない(SHOULD NOT)としています。DNS を偽造できる攻撃者はいずれにせよレコードを置き換えられますし、メールサーバー間には信頼する CA の共通リストがないためです。

dane-ta

DANE-TA(2)は、トラストアンカー(通常は発行元の CA)を DNS でピン留めします。

用途 2 では、サーバーのチェーンは TLSA レコードにある証明書または鍵にたどり着かなければなりません。その証明書や鍵は公開 CA のものである必要はありません。RFC 7672 §3.1.2 は、レコードが証明書全体ではなく鍵と一致する場合、サーバーがチェーン内でトラストアンカーを送信することを求めています。

dane-ee

DANE-EE(3)は、サーバー自身の証明書または鍵を DNS でピン留めします。証明書内の名前と有効期限は確認されません。

用途 3 では、TLSA レコードだけで鍵と名前が結び付けられます。RFC 7672 §3.1.1 によると、証明書内のどの名前とも一致しなくてもサーバーは認証され、証明書の有効期限は無視しなければなりません(MUST)。よく使われるレコード「3 1 1」(DANE-EE、SPKI、SHA-256)は、鍵が変わらない限り証明書を更新してもそのまま使えます。

DANE TLSA のセレクター · 4 件

TLSA レコードの 2 番目のフィールドです。

値略称説明参考文献
0CertCert(0)は TLSA のセレクター「Full certificate」です。RFC 6698
1SPKISPKI(1)は TLSA のセレクター「SubjectPublicKeyInfo」です。RFC 6698
2C509C509(2)は TLSA のセレクター「C509Certificate」です。RFC-ietf-cose-cbor-encoded-cert-21
255PrivSelPrivSel(255)は TLSA のセレクター「Reserved for Private Use」です。RFC 6698
未割り当ての範囲と予約済みの範囲 · 1 件
範囲ステータス説明
3–254unassignedUnassigned

出典:DNS-Based Authentication of Named Entities (DANE) Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 TLSA Selectors

DANE TLSA のマッチングタイプ · 4 件

TLSA レコードの 3 番目のフィールドです。

値略称説明参考文献
0FullFull(0)は TLSA のマッチングタイプ「No hash used」です。RFC 6698
1SHA2-256SHA2-256(1)は TLSA のマッチングタイプ「256 bit hash by SHA2」です。RFC 6234
2SHA2-512SHA2-512(2)は TLSA のマッチングタイプ「512 bit hash by SHA2」です。RFC 6234
255PrivMatchPrivMatch(255)は TLSA のマッチングタイプ「Reserved for Private Use」です。RFC 6698
未割り当ての範囲と予約済みの範囲 · 1 件
範囲ステータス説明
3–254unassignedUnassigned

出典:DNS-Based Authentication of Named Entities (DANE) Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 TLSA Matching Types

すべてのレジストリ