クライアントは status_request 拡張で要求します(RFC 6066 §8)。TLS 1.3 では、サーバーはリーフ証明書の CertificateEntry の拡張の中でレスポンスを返します(RFC 9846 §4.5.1.1)。中間証明書向けに RFC 6961 が定めたマルチステープリングの方式は、ほとんど使われませんでした。Must-Staple 証明書拡張(RFC 7633)は、ステープルされたレスポンスのないハンドシェイクを拒否するようクライアントに指示するものでしたが、対応していたのは Firefox だけでした。
ステープリングはプライバシーの問題を解決しましたが、可用性の問題は解決しませんでした。レスポンスの更新に失敗したサーバーは、自分のサイトを壊してしまったからです。公的な CA が OCSP をやめつつある今(Let's Encrypt は 2025年8月6日にレスポンダーを停止し、Must-Staple の注文の受け付けもやめました)、そうした証明書ではステープリングはなくなります。サーバーは、OCSP の URL がないことを理由に起動に失敗すべきではありません。