客户端通过 status_request 扩展发出请求(RFC 6066 §8);在 TLS 1.3 中,服务器把响应放在其叶子证书的 CertificateEntry 扩展中返回(RFC 9846 §4.5.1.1)。RFC 6961 为中间证书设计的多重 stapling 变体很少有人使用。Must-Staple 证书扩展(RFC 7633)曾要求客户端拒绝没有附带 stapling 响应的握手,但只有 Firefox 支持它。
Stapling 解决了隐私问题,却没有解决可用性问题:未能及时刷新响应的服务器会导致自己的网站无法访问。随着公共 CA 放弃 OCSP(Let's Encrypt 于2025年8月6日关闭了响应器,并停止接受 Must-Staple 订单),这些证书也就不再有 stapling;证书中没有 OCSP URL 时,服务器不应因此启动失败。