直接モード(alg: ECDH-ES)では、導出した鍵がそのままコンテンツ暗号化鍵になり、JWE の暗号化された鍵の部分は空になります。ラップモード(ECDH-ES+A128KW、+A192KW、+A256KW)では、導出した鍵でランダムな CEK をラップするため、複数の受信者に対応できます。ヘッダーには一時公開鍵 epk と、任意の apu と apv(当事者情報)が含まれ、これらはアルゴリズム名と鍵長とともに KDF に入力されます(§4.6.2)。使用できるのは P-256、P-384、P-521 と、RFC 8037 による X25519 と X448 です。
受信者は epk を検証しなければなりません。2017年には複数の JOSE ライブラリが曲線上にない点を受け入れており、攻撃者は無効曲線を使ったクエリで受信者の秘密鍵を復元できました(RFC 8725 §2.5)。ECDH-ES では、メッセージの送信者が誰なのかを受信者が確かめる手段がありません。それが重要な場合は、先に署名してください(ネストされた JWT)。HPKE(RFC 9180)はこれを現代的に一般化したもので、JOSE で HPKE を使うための作業が進んでいます。