TLS_NULL_WITH_NULL_NULL
最初のハンドシェイクが完了する前の接続に置かれる、仮のスイートです。鍵交換も認証も保護もありません。
TLS_NULL_WITH_NULL_NULL(0x00,0x00)は TLS 1.2 接続の初期状態を表します(RFC 5246 §6.1)。ネゴシエートされることはなく、これを選択するサーバーには深刻なバグがあります。
372 件中 372 件を表示
IANA の TLS レジストリに登録された全 372 件の暗号スイートを、OpenSSL・GnuTLS・NSS での名前、鍵交換、暗号、MAC、安全性の評価とともに掲載しています。
| 値 | 名称 | プロトコルバージョン | 評価 | 推奨 |
|---|---|---|---|---|
0x00,0x00注記 | TLS_NULL_WITH_NULL_NULL | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x01 | TLS_RSA_WITH_NULL_MD5OpenSSL での名前は NULL-MD5 です。 GnuTLS での名前は TLS_RSA_NULL_MD5 です。 NSS での名前は TLS_RSA_WITH_NULL_MD5 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x02 | TLS_RSA_WITH_NULL_SHAOpenSSL での名前は NULL-SHA です。 GnuTLS での名前は TLS_RSA_NULL_SHA1 です。 NSS での名前は TLS_RSA_WITH_NULL_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x03 | TLS_RSA_EXPORT_WITH_RC4_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x04 | TLS_RSA_WITH_RC4_128_MD5OpenSSL での名前は RC4-MD5 です。 GnuTLS での名前は TLS_RSA_ARCFOUR_128_MD5 です。 NSS での名前は TLS_RSA_WITH_RC4_128_MD5 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x05注記 | TLS_RSA_WITH_RC4_128_SHAOpenSSL での名前は RC4-SHA です。 GnuTLS での名前は TLS_RSA_ARCFOUR_128_SHA1 です。 NSS での名前は TLS_RSA_WITH_RC4_128_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x06 | TLS_RSA_EXPORT_WITH_RC2_CBC_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、40 ビット鍵の RC2、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x07 | TLS_RSA_WITH_IDEA_CBC_SHAOpenSSL での名前は IDEA-CBC-SHA です。 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x08 | TLS_RSA_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x09 | TLS_RSA_WITH_DES_CBC_SHANSS での名前は TLS_RSA_WITH_DES_CBC_SHA です。 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0A注記 | TLS_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は DES-CBC3-SHA です。 GnuTLS での名前は TLS_RSA_3DES_EDE_CBC_SHA1 です。 NSS での名前は TLS_RSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0B | TLS_DH_DSS_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0C | TLS_DH_DSS_WITH_DES_CBC_SHA | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0D | TLS_DH_DSS_WITH_3DES_EDE_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0E | TLS_DH_RSA_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x0F | TLS_DH_RSA_WITH_DES_CBC_SHA | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x10 | TLS_DH_RSA_WITH_3DES_EDE_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x11 | TLS_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x12 | TLS_DHE_DSS_WITH_DES_CBC_SHANSS での名前は TLS_DHE_DSS_WITH_DES_CBC_SHA です。 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x13 | TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は DHE-DSS-DES-CBC3-SHA です。 GnuTLS での名前は TLS_DHE_DSS_3DES_EDE_CBC_SHA1 です。 NSS での名前は TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x14 | TLS_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x15 | TLS_DHE_RSA_WITH_DES_CBC_SHANSS での名前は TLS_DHE_RSA_WITH_DES_CBC_SHA です。 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x16 | TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は DHE-RSA-DES-CBC3-SHA です。 GnuTLS での名前は TLS_DHE_RSA_3DES_EDE_CBC_SHA1 です。 NSS での名前は TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x17 | TLS_DH_anon_EXPORT_WITH_RC4_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x18 | TLS_DH_anon_WITH_RC4_128_MD5OpenSSL での名前は ADH-RC4-MD5 です。 GnuTLS での名前は TLS_DH_ANON_ARCFOUR_128_MD5 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x19 | TLS_DH_anon_EXPORT_WITH_DES40_CBC_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x1A | TLS_DH_anon_WITH_DES_CBC_SHA | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x1B | TLS_DH_anon_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は ADH-DES-CBC3-SHA です。 GnuTLS での名前は TLS_DH_ANON_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x1E | TLS_KRB5_WITH_DES_CBC_SHA | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x1F | TLS_KRB5_WITH_3DES_EDE_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x20 | TLS_KRB5_WITH_RC4_128_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x21 | TLS_KRB5_WITH_IDEA_CBC_SHA | TLS 1.0, TLS 1.1 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x22 | TLS_KRB5_WITH_DES_CBC_MD5 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:安全でない。弱点:シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x23 | TLS_KRB5_WITH_3DES_EDE_CBC_MD5 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x24 | TLS_KRB5_WITH_RC4_128_MD5 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x25 | TLS_KRB5_WITH_IDEA_CBC_MD5 | TLS 1.0, TLS 1.1 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x26 | TLS_KRB5_EXPORT_WITH_DES_CBC_40_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x27 | TLS_KRB5_EXPORT_WITH_RC2_CBC_40_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、40 ビット鍵の RC2、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x28 | TLS_KRB5_EXPORT_WITH_RC4_40_SHA | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x29 | TLS_KRB5_EXPORT_WITH_DES_CBC_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、シングル DES(56 ビットの鍵は全数探索で見つかる)、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2A | TLS_KRB5_EXPORT_WITH_RC2_CBC_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、40 ビット鍵の RC2、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2B | TLS_KRB5_EXPORT_WITH_RC4_40_MD5 | TLS 1.0 | ecdsa.com の評価:安全でない。弱点:意図的に弱められた 1990 年代の輸出グレード暗号(FREAK、Logjam)、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、HMAC-MD5、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2C | TLS_PSK_WITH_NULL_SHAOpenSSL での名前は PSK-NULL-SHA です。 GnuTLS での名前は TLS_PSK_NULL_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2D | TLS_DHE_PSK_WITH_NULL_SHAOpenSSL での名前は DHE-PSK-NULL-SHA です。 GnuTLS での名前は TLS_DHE_PSK_NULL_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2E | TLS_RSA_PSK_WITH_NULL_SHAOpenSSL での名前は RSA-PSK-NULL-SHA です。 GnuTLS での名前は TLS_RSA_PSK_NULL_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x2F注記 | TLS_RSA_WITH_AES_128_CBC_SHAOpenSSL での名前は AES128-SHA です。 GnuTLS での名前は TLS_RSA_AES_128_CBC_SHA1 です。 NSS での名前は TLS_RSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x30 | TLS_DH_DSS_WITH_AES_128_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x31 | TLS_DH_RSA_WITH_AES_128_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x32 | TLS_DHE_DSS_WITH_AES_128_CBC_SHAOpenSSL での名前は DHE-DSS-AES128-SHA です。 GnuTLS での名前は TLS_DHE_DSS_AES_128_CBC_SHA1 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x33 | TLS_DHE_RSA_WITH_AES_128_CBC_SHAOpenSSL での名前は DHE-RSA-AES128-SHA です。 GnuTLS での名前は TLS_DHE_RSA_AES_128_CBC_SHA1 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x34 | TLS_DH_anon_WITH_AES_128_CBC_SHAOpenSSL での名前は ADH-AES128-SHA です。 GnuTLS での名前は TLS_DH_ANON_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x35 | TLS_RSA_WITH_AES_256_CBC_SHAOpenSSL での名前は AES256-SHA です。 GnuTLS での名前は TLS_RSA_AES_256_CBC_SHA1 です。 NSS での名前は TLS_RSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x36 | TLS_DH_DSS_WITH_AES_256_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x37 | TLS_DH_RSA_WITH_AES_256_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x38 | TLS_DHE_DSS_WITH_AES_256_CBC_SHAOpenSSL での名前は DHE-DSS-AES256-SHA です。 GnuTLS での名前は TLS_DHE_DSS_AES_256_CBC_SHA1 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x39 | TLS_DHE_RSA_WITH_AES_256_CBC_SHAOpenSSL での名前は DHE-RSA-AES256-SHA です。 GnuTLS での名前は TLS_DHE_RSA_AES_256_CBC_SHA1 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3A | TLS_DH_anon_WITH_AES_256_CBC_SHAOpenSSL での名前は ADH-AES256-SHA です。 GnuTLS での名前は TLS_DH_ANON_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3B | TLS_RSA_WITH_NULL_SHA256OpenSSL での名前は NULL-SHA256 です。 GnuTLS での名前は TLS_RSA_NULL_SHA256 です。 NSS での名前は TLS_RSA_WITH_NULL_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3C | TLS_RSA_WITH_AES_128_CBC_SHA256OpenSSL での名前は AES128-SHA256 です。 GnuTLS での名前は TLS_RSA_AES_128_CBC_SHA256 です。 NSS での名前は TLS_RSA_WITH_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3D | TLS_RSA_WITH_AES_256_CBC_SHA256OpenSSL での名前は AES256-SHA256 です。 GnuTLS での名前は TLS_RSA_AES_256_CBC_SHA256 です。 NSS での名前は TLS_RSA_WITH_AES_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3E | TLS_DH_DSS_WITH_AES_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x3F | TLS_DH_RSA_WITH_AES_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x40 | TLS_DHE_DSS_WITH_AES_128_CBC_SHA256OpenSSL での名前は DHE-DSS-AES128-SHA256 です。 GnuTLS での名前は TLS_DHE_DSS_AES_128_CBC_SHA256 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x41 | TLS_RSA_WITH_CAMELLIA_128_CBC_SHAOpenSSL での名前は CAMELLIA128-SHA です。 GnuTLS での名前は TLS_RSA_CAMELLIA_128_CBC_SHA1 です。 NSS での名前は TLS_RSA_WITH_CAMELLIA_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x42 | TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x43 | TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x44 | TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHAOpenSSL での名前は DHE-DSS-CAMELLIA128-SHA です。 GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_128_CBC_SHA1 です。 NSS での名前は TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x45 | TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHAOpenSSL での名前は DHE-RSA-CAMELLIA128-SHA です。 GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_128_CBC_SHA1 です。 NSS での名前は TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x46 | TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHAOpenSSL での名前は ADH-CAMELLIA128-SHA です。 GnuTLS での名前は TLS_DH_ANON_CAMELLIA_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x67 | TLS_DHE_RSA_WITH_AES_128_CBC_SHA256OpenSSL での名前は DHE-RSA-AES128-SHA256 です。 GnuTLS での名前は TLS_DHE_RSA_AES_128_CBC_SHA256 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x68 | TLS_DH_DSS_WITH_AES_256_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x69 | TLS_DH_RSA_WITH_AES_256_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x6A | TLS_DHE_DSS_WITH_AES_256_CBC_SHA256OpenSSL での名前は DHE-DSS-AES256-SHA256 です。 GnuTLS での名前は TLS_DHE_DSS_AES_256_CBC_SHA256 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x6B | TLS_DHE_RSA_WITH_AES_256_CBC_SHA256OpenSSL での名前は DHE-RSA-AES256-SHA256 です。 GnuTLS での名前は TLS_DHE_RSA_AES_256_CBC_SHA256 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x6C | TLS_DH_anon_WITH_AES_128_CBC_SHA256OpenSSL での名前は ADH-AES128-SHA256 です。 GnuTLS での名前は TLS_DH_ANON_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x6D | TLS_DH_anon_WITH_AES_256_CBC_SHA256OpenSSL での名前は ADH-AES256-SHA256 です。 GnuTLS での名前は TLS_DH_ANON_AES_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x6E | TLS_ASCONAEAD128_ASCONHASH256 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0x6F | TLS_ASCONAEAD128_SHA256 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0x70 | TLS_AES_128_GCM_ASCONHASH256 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0x71 | TLS_AES_128_CCM_ASCONHASH256 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0x84 | TLS_RSA_WITH_CAMELLIA_256_CBC_SHAOpenSSL での名前は CAMELLIA256-SHA です。 GnuTLS での名前は TLS_RSA_CAMELLIA_256_CBC_SHA1 です。 NSS での名前は TLS_RSA_WITH_CAMELLIA_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x85 | TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x86 | TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x87 | TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHAOpenSSL での名前は DHE-DSS-CAMELLIA256-SHA です。 GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_256_CBC_SHA1 です。 NSS での名前は TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x88 | TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHAOpenSSL での名前は DHE-RSA-CAMELLIA256-SHA です。 GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_256_CBC_SHA1 です。 NSS での名前は TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x89 | TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHAOpenSSL での名前は ADH-CAMELLIA256-SHA です。 GnuTLS での名前は TLS_DH_ANON_CAMELLIA_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x8A | TLS_PSK_WITH_RC4_128_SHAOpenSSL での名前は PSK-RC4-SHA です。 GnuTLS での名前は TLS_PSK_ARCFOUR_128_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x8B | TLS_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は PSK-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_PSK_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x8C | TLS_PSK_WITH_AES_128_CBC_SHAOpenSSL での名前は PSK-AES128-CBC-SHA です。 GnuTLS での名前は TLS_PSK_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x8D | TLS_PSK_WITH_AES_256_CBC_SHAOpenSSL での名前は PSK-AES256-CBC-SHA です。 GnuTLS での名前は TLS_PSK_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0x8E | TLS_DHE_PSK_WITH_RC4_128_SHAOpenSSL での名前は DHE-PSK-RC4-SHA です。 GnuTLS での名前は TLS_DHE_PSK_ARCFOUR_128_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x8F | TLS_DHE_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は DHE-PSK-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_DHE_PSK_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x90 | TLS_DHE_PSK_WITH_AES_128_CBC_SHAOpenSSL での名前は DHE-PSK-AES128-CBC-SHA です。 GnuTLS での名前は TLS_DHE_PSK_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x91 | TLS_DHE_PSK_WITH_AES_256_CBC_SHAOpenSSL での名前は DHE-PSK-AES256-CBC-SHA です。 GnuTLS での名前は TLS_DHE_PSK_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x92 | TLS_RSA_PSK_WITH_RC4_128_SHAOpenSSL での名前は RSA-PSK-RC4-SHA です。 GnuTLS での名前は TLS_RSA_PSK_ARCFOUR_128_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x93 | TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は RSA-PSK-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_RSA_PSK_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x94 | TLS_RSA_PSK_WITH_AES_128_CBC_SHAOpenSSL での名前は RSA-PSK-AES128-CBC-SHA です。 GnuTLS での名前は TLS_RSA_PSK_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x95 | TLS_RSA_PSK_WITH_AES_256_CBC_SHAOpenSSL での名前は RSA-PSK-AES256-CBC-SHA です。 GnuTLS での名前は TLS_RSA_PSK_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x96 | TLS_RSA_WITH_SEED_CBC_SHAOpenSSL での名前は SEED-SHA です。 NSS での名前は TLS_RSA_WITH_SEED_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x97 | TLS_DH_DSS_WITH_SEED_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x98 | TLS_DH_RSA_WITH_SEED_CBC_SHA | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x99 | TLS_DHE_DSS_WITH_SEED_CBC_SHAOpenSSL での名前は DHE-DSS-SEED-SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x9A | TLS_DHE_RSA_WITH_SEED_CBC_SHAOpenSSL での名前は DHE-RSA-SEED-SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x9B | TLS_DH_anon_WITH_SEED_CBC_SHAOpenSSL での名前は ADH-SEED-SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x9C | TLS_RSA_WITH_AES_128_GCM_SHA256OpenSSL での名前は AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_RSA_AES_128_GCM_SHA256 です。 NSS での名前は TLS_RSA_WITH_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x9D | TLS_RSA_WITH_AES_256_GCM_SHA384OpenSSL での名前は AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_RSA_AES_256_GCM_SHA384 です。 NSS での名前は TLS_RSA_WITH_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0x9E | TLS_DHE_RSA_WITH_AES_128_GCM_SHA256OpenSSL での名前は DHE-RSA-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_DHE_RSA_AES_128_GCM_SHA256 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0x9F | TLS_DHE_RSA_WITH_AES_256_GCM_SHA384OpenSSL での名前は DHE-RSA-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_DHE_RSA_AES_256_GCM_SHA384 です。 NSS での名前は TLS_DHE_RSA_WITH_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0xA0 | TLS_DH_RSA_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA1 | TLS_DH_RSA_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA2 | TLS_DHE_DSS_WITH_AES_128_GCM_SHA256OpenSSL での名前は DHE-DSS-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_DHE_DSS_AES_128_GCM_SHA256 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0xA3 | TLS_DHE_DSS_WITH_AES_256_GCM_SHA384OpenSSL での名前は DHE-DSS-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_DHE_DSS_AES_256_GCM_SHA384 です。 NSS での名前は TLS_DHE_DSS_WITH_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0xA4 | TLS_DH_DSS_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA5 | TLS_DH_DSS_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA6 | TLS_DH_anon_WITH_AES_128_GCM_SHA256OpenSSL での名前は ADH-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_DH_ANON_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA7 | TLS_DH_anon_WITH_AES_256_GCM_SHA384OpenSSL での名前は ADH-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_DH_ANON_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xA8 | TLS_PSK_WITH_AES_128_GCM_SHA256OpenSSL での名前は PSK-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_PSK_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0xA9 | TLS_PSK_WITH_AES_256_GCM_SHA384OpenSSL での名前は PSK-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_PSK_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0xAA | TLS_DHE_PSK_WITH_AES_128_GCM_SHA256OpenSSL での名前は DHE-PSK-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_DHE_PSK_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0xAB | TLS_DHE_PSK_WITH_AES_256_GCM_SHA384OpenSSL での名前は DHE-PSK-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_DHE_PSK_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0x00,0xAC | TLS_RSA_PSK_WITH_AES_128_GCM_SHA256OpenSSL での名前は RSA-PSK-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_RSA_PSK_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xAD | TLS_RSA_PSK_WITH_AES_256_GCM_SHA384OpenSSL での名前は RSA-PSK-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_RSA_PSK_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xAE | TLS_PSK_WITH_AES_128_CBC_SHA256OpenSSL での名前は PSK-AES128-CBC-SHA256 です。 GnuTLS での名前は TLS_PSK_AES_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0xAF | TLS_PSK_WITH_AES_256_CBC_SHA384OpenSSL での名前は PSK-AES256-CBC-SHA384 です。 GnuTLS での名前は TLS_PSK_AES_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0x00,0xB0 | TLS_PSK_WITH_NULL_SHA256OpenSSL での名前は PSK-NULL-SHA256 です。 GnuTLS での名前は TLS_PSK_NULL_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB1 | TLS_PSK_WITH_NULL_SHA384OpenSSL での名前は PSK-NULL-SHA384 です。 GnuTLS での名前は TLS_PSK_NULL_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB2 | TLS_DHE_PSK_WITH_AES_128_CBC_SHA256OpenSSL での名前は DHE-PSK-AES128-CBC-SHA256 です。 GnuTLS での名前は TLS_DHE_PSK_AES_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB3 | TLS_DHE_PSK_WITH_AES_256_CBC_SHA384OpenSSL での名前は DHE-PSK-AES256-CBC-SHA384 です。 GnuTLS での名前は TLS_DHE_PSK_AES_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB4 | TLS_DHE_PSK_WITH_NULL_SHA256OpenSSL での名前は DHE-PSK-NULL-SHA256 です。 GnuTLS での名前は TLS_DHE_PSK_NULL_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB5 | TLS_DHE_PSK_WITH_NULL_SHA384OpenSSL での名前は DHE-PSK-NULL-SHA384 です。 GnuTLS での名前は TLS_DHE_PSK_NULL_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB6 | TLS_RSA_PSK_WITH_AES_128_CBC_SHA256OpenSSL での名前は RSA-PSK-AES128-CBC-SHA256 です。 GnuTLS での名前は TLS_RSA_PSK_AES_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB7 | TLS_RSA_PSK_WITH_AES_256_CBC_SHA384OpenSSL での名前は RSA-PSK-AES256-CBC-SHA384 です。 GnuTLS での名前は TLS_RSA_PSK_AES_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB8 | TLS_RSA_PSK_WITH_NULL_SHA256OpenSSL での名前は RSA-PSK-NULL-SHA256 です。 GnuTLS での名前は TLS_RSA_PSK_NULL_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xB9 | TLS_RSA_PSK_WITH_NULL_SHA384OpenSSL での名前は RSA-PSK-NULL-SHA384 です。 GnuTLS での名前は TLS_RSA_PSK_NULL_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBA | TLS_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_RSA_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBB | TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBC | TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBD | TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は DHE-DSS-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBE | TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は DHE-RSA-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xBF | TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は ADH-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_DH_ANON_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC0 | TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256OpenSSL での名前は CAMELLIA256-SHA256 です。 GnuTLS での名前は TLS_RSA_CAMELLIA_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC1 | TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC2 | TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC3 | TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA256OpenSSL での名前は DHE-DSS-CAMELLIA256-SHA256 です。 GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC4 | TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256OpenSSL での名前は DHE-RSA-CAMELLIA256-SHA256 です。 GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC5 | TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA256OpenSSL での名前は ADH-CAMELLIA256-SHA256 です。 GnuTLS での名前は TLS_DH_ANON_CAMELLIA_256_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0x00,0xC6 | TLS_SM4_GCM_SM3OpenSSL での名前は TLS_SM4_GCM_SM3 です。 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0xC7 | TLS_SM4_CCM_SM3OpenSSL での名前は TLS_SM4_CCM_SM3 です。 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x00,0xFF注記 | TLS_EMPTY_RENEGOTIATION_INFO_SCSV | — | N | |
0x0A,0x0A | Reserved | — | N | |
0x13,0x01注記 | TLS_AES_128_GCM_SHA256OpenSSL での名前は TLS_AES_128_GCM_SHA256 です。 GnuTLS での名前は TLS_AES_128_GCM_SHA256 です。 NSS での名前は TLS_AES_128_GCM_SHA256 です。 | TLS 1.3 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0x13,0x02注記 | TLS_AES_256_GCM_SHA384OpenSSL での名前は TLS_AES_256_GCM_SHA384 です。 GnuTLS での名前は TLS_AES_256_GCM_SHA384 です。 NSS での名前は TLS_AES_256_GCM_SHA384 です。 | TLS 1.3 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0x13,0x03注記 | TLS_CHACHA20_POLY1305_SHA256OpenSSL での名前は TLS_CHACHA20_POLY1305_SHA256 です。 GnuTLS での名前は TLS_CHACHA20_POLY1305_SHA256 です。 NSS での名前は TLS_CHACHA20_POLY1305_SHA256 です。 | TLS 1.3 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0x13,0x04注記 | TLS_AES_128_CCM_SHA256OpenSSL での名前は TLS_AES_128_CCM_SHA256 です。 GnuTLS での名前は TLS_AES_128_CCM_SHA256 です。 | TLS 1.3 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0x13,0x05 | TLS_AES_128_CCM_8_SHA256OpenSSL での名前は TLS_AES_128_CCM_8_SHA256 です。 GnuTLS での名前は TLS_AES_128_CCM_8_SHA256 です。 | TLS 1.3 | ecdsa.com の評価:安全。弱点:IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0x13,0x06 | TLS_AEGIS_256_SHA512 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x13,0x07 | TLS_AEGIS_128L_SHA256 | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0x1A,0x1A | Reserved | — | N | |
0x2A,0x2A | Reserved | — | N | |
0x3A,0x3A | Reserved | — | N | |
0x4A,0x4A | Reserved | — | N | |
0x56,0x00注記 | TLS_FALLBACK_SCSV | — | N | |
0x5A,0x5A | Reserved | — | N | |
0x6A,0x6A | Reserved | — | N | |
0x7A,0x7A | Reserved | — | N | |
0x8A,0x8A | Reserved | — | N | |
0x9A,0x9A | Reserved | — | N | |
0xAA,0xAA | Reserved | — | N | |
0xBA,0xBA | Reserved | — | N | |
0xC0,0x01 | TLS_ECDH_ECDSA_WITH_NULL_SHANSS での名前は TLS_ECDH_ECDSA_WITH_NULL_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x02 | TLS_ECDH_ECDSA_WITH_RC4_128_SHANSS での名前は TLS_ECDH_ECDSA_WITH_RC4_128_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x03 | TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHANSS での名前は TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x04 | TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHANSS での名前は TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x05 | TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHANSS での名前は TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x06 | TLS_ECDHE_ECDSA_WITH_NULL_SHAOpenSSL での名前は ECDHE-ECDSA-NULL-SHA です。 GnuTLS での名前は TLS_ECDHE_ECDSA_NULL_SHA1 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_NULL_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x07 | TLS_ECDHE_ECDSA_WITH_RC4_128_SHAOpenSSL での名前は ECDHE-ECDSA-RC4-SHA です。 GnuTLS での名前は TLS_ECDHE_ECDSA_ARCFOUR_128_SHA1 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_RC4_128_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x08 | TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は ECDHE-ECDSA-DES-CBC3-SHA です。 GnuTLS での名前は TLS_ECDHE_ECDSA_3DES_EDE_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x09 | TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHAOpenSSL での名前は ECDHE-ECDSA-AES128-SHA です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_128_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x0A | TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHAOpenSSL での名前は ECDHE-ECDSA-AES256-SHA です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_256_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x0B | TLS_ECDH_RSA_WITH_NULL_SHANSS での名前は TLS_ECDH_RSA_WITH_NULL_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x0C | TLS_ECDH_RSA_WITH_RC4_128_SHANSS での名前は TLS_ECDH_RSA_WITH_RC4_128_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x0D | TLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHANSS での名前は TLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x0E | TLS_ECDH_RSA_WITH_AES_128_CBC_SHANSS での名前は TLS_ECDH_RSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x0F | TLS_ECDH_RSA_WITH_AES_256_CBC_SHANSS での名前は TLS_ECDH_RSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x10 | TLS_ECDHE_RSA_WITH_NULL_SHAOpenSSL での名前は ECDHE-RSA-NULL-SHA です。 GnuTLS での名前は TLS_ECDHE_RSA_NULL_SHA1 です。 NSS での名前は TLS_ECDHE_RSA_WITH_NULL_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x11 | TLS_ECDHE_RSA_WITH_RC4_128_SHAOpenSSL での名前は ECDHE-RSA-RC4-SHA です。 GnuTLS での名前は TLS_ECDHE_RSA_ARCFOUR_128_SHA1 です。 NSS での名前は TLS_ECDHE_RSA_WITH_RC4_128_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x12 | TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は ECDHE-RSA-DES-CBC3-SHA です。 GnuTLS での名前は TLS_ECDHE_RSA_3DES_EDE_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x13 | TLS_ECDHE_RSA_WITH_AES_128_CBC_SHAOpenSSL での名前は ECDHE-RSA-AES128-SHA です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_128_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x14 | TLS_ECDHE_RSA_WITH_AES_256_CBC_SHAOpenSSL での名前は ECDHE-RSA-AES256-SHA です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_256_CBC_SHA1 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x15 | TLS_ECDH_anon_WITH_NULL_SHAOpenSSL での名前は AECDH-NULL-SHA です。 GnuTLS での名前は TLS_ECDH_ANON_NULL_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x16 | TLS_ECDH_anon_WITH_RC4_128_SHAOpenSSL での名前は AECDH-RC4-SHA です。 GnuTLS での名前は TLS_ECDH_ANON_ARCFOUR_128_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x17 | TLS_ECDH_anon_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は AECDH-DES-CBC3-SHA です。 GnuTLS での名前は TLS_ECDH_ANON_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x18 | TLS_ECDH_anon_WITH_AES_128_CBC_SHAOpenSSL での名前は AECDH-AES128-SHA です。 GnuTLS での名前は TLS_ECDH_ANON_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x19 | TLS_ECDH_anon_WITH_AES_256_CBC_SHAOpenSSL での名前は AECDH-AES256-SHA です。 GnuTLS での名前は TLS_ECDH_ANON_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x1A | TLS_SRP_SHA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は SRP-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x1B | TLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は SRP-RSA-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_RSA_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x1C | TLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は SRP-DSS-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_DSS_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x1D | TLS_SRP_SHA_WITH_AES_128_CBC_SHAOpenSSL での名前は SRP-AES-128-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x1E | TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHAOpenSSL での名前は SRP-RSA-AES-128-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_RSA_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x1F | TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHAOpenSSL での名前は SRP-DSS-AES-128-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_DSS_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x20 | TLS_SRP_SHA_WITH_AES_256_CBC_SHAOpenSSL での名前は SRP-AES-256-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x21 | TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHAOpenSSL での名前は SRP-RSA-AES-256-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_RSA_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x22 | TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHAOpenSSL での名前は SRP-DSS-AES-256-CBC-SHA です。 GnuTLS での名前は TLS_SRP_SHA_DSS_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x23 | TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256OpenSSL での名前は ECDHE-ECDSA-AES128-SHA256 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_128_CBC_SHA256 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x24 | TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384OpenSSL での名前は ECDHE-ECDSA-AES256-SHA384 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_256_CBC_SHA384 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x25 | TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x26 | TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x27 | TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256OpenSSL での名前は ECDHE-RSA-AES128-SHA256 です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_128_CBC_SHA256 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x28 | TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384OpenSSL での名前は ECDHE-RSA-AES256-SHA384 です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_256_CBC_SHA384 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x29 | TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x2A | TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x2B注記 | TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256OpenSSL での名前は ECDHE-ECDSA-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_128_GCM_SHA256 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xC0,0x2C | TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384OpenSSL での名前は ECDHE-ECDSA-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_256_GCM_SHA384 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xC0,0x2D | TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x2E | TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x2F注記 | TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256OpenSSL での名前は ECDHE-RSA-AES128-GCM-SHA256 です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_128_GCM_SHA256 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xC0,0x30注記 | TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384OpenSSL での名前は ECDHE-RSA-AES256-GCM-SHA384 です。 GnuTLS での名前は TLS_ECDHE_RSA_AES_256_GCM_SHA384 です。 NSS での名前は TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xC0,0x31 | TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x32 | TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x33 | TLS_ECDHE_PSK_WITH_RC4_128_SHAOpenSSL での名前は ECDHE-PSK-RC4-SHA です。 GnuTLS での名前は TLS_ECDHE_PSK_ARCFOUR_128_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:偏りがあるため TLS での使用が禁止されている RC4(RFC 7465)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x34 | TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL での名前は ECDHE-PSK-3DES-EDE-CBC-SHA です。 GnuTLS での名前は TLS_ECDHE_PSK_3DES_EDE_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:Sweet32 などの誕生日攻撃を受ける 64 ビットブロック暗号、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x35 | TLS_ECDHE_PSK_WITH_AES_128_CBC_SHAOpenSSL での名前は ECDHE-PSK-AES128-CBC-SHA です。 GnuTLS での名前は TLS_ECDHE_PSK_AES_128_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x36 | TLS_ECDHE_PSK_WITH_AES_256_CBC_SHAOpenSSL での名前は ECDHE-PSK-AES256-CBC-SHA です。 GnuTLS での名前は TLS_ECDHE_PSK_AES_256_CBC_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x37 | TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA256OpenSSL での名前は ECDHE-PSK-AES128-CBC-SHA256 です。 GnuTLS での名前は TLS_ECDHE_PSK_AES_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x38 | TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA384OpenSSL での名前は ECDHE-PSK-AES256-CBC-SHA384 です。 GnuTLS での名前は TLS_ECDHE_PSK_AES_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x39 | TLS_ECDHE_PSK_WITH_NULL_SHAOpenSSL での名前は ECDHE-PSK-NULL-SHA です。 GnuTLS での名前は TLS_ECDHE_PSK_NULL_SHA1 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3A | TLS_ECDHE_PSK_WITH_NULL_SHA256OpenSSL での名前は ECDHE-PSK-NULL-SHA256 です。 GnuTLS での名前は TLS_ECDHE_PSK_NULL_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3B | TLS_ECDHE_PSK_WITH_NULL_SHA384OpenSSL での名前は ECDHE-PSK-NULL-SHA384 です。 GnuTLS での名前は TLS_ECDHE_PSK_NULL_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3C | TLS_RSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3D | TLS_RSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3E | TLS_DH_DSS_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x3F | TLS_DH_DSS_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x40 | TLS_DH_RSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x41 | TLS_DH_RSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x42 | TLS_DHE_DSS_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x43 | TLS_DHE_DSS_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x44 | TLS_DHE_RSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x45 | TLS_DHE_RSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x46 | TLS_DH_anon_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x47 | TLS_DH_anon_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x48 | TLS_ECDHE_ECDSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x49 | TLS_ECDHE_ECDSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x4A | TLS_ECDH_ECDSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x4B | TLS_ECDH_ECDSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x4C | TLS_ECDHE_RSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x4D | TLS_ECDHE_RSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x4E | TLS_ECDH_RSA_WITH_ARIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x4F | TLS_ECDH_RSA_WITH_ARIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x50 | TLS_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x51 | TLS_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x52 | TLS_DHE_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は DHE-RSA-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x53 | TLS_DHE_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は DHE-RSA-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x54 | TLS_DH_RSA_WITH_ARIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x55 | TLS_DH_RSA_WITH_ARIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x56 | TLS_DHE_DSS_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は DHE-DSS-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x57 | TLS_DHE_DSS_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は DHE-DSS-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x58 | TLS_DH_DSS_WITH_ARIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x59 | TLS_DH_DSS_WITH_ARIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x5A | TLS_DH_anon_WITH_ARIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x5B | TLS_DH_anon_WITH_ARIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x5C | TLS_ECDHE_ECDSA_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は ECDHE-ECDSA-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x5D | TLS_ECDHE_ECDSA_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は ECDHE-ECDSA-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x5E | TLS_ECDH_ECDSA_WITH_ARIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x5F | TLS_ECDH_ECDSA_WITH_ARIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x60 | TLS_ECDHE_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は ECDHE-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x61 | TLS_ECDHE_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は ECDHE-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x62 | TLS_ECDH_RSA_WITH_ARIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x63 | TLS_ECDH_RSA_WITH_ARIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x64 | TLS_PSK_WITH_ARIA_128_CBC_SHA256 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x65 | TLS_PSK_WITH_ARIA_256_CBC_SHA384 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x66 | TLS_DHE_PSK_WITH_ARIA_128_CBC_SHA256 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x67 | TLS_DHE_PSK_WITH_ARIA_256_CBC_SHA384 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x68 | TLS_RSA_PSK_WITH_ARIA_128_CBC_SHA256 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x69 | TLS_RSA_PSK_WITH_ARIA_256_CBC_SHA384 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x6A | TLS_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は PSK-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x6B | TLS_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は PSK-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x6C | TLS_DHE_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は DHE-PSK-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x6D | TLS_DHE_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は DHE-PSK-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x6E | TLS_RSA_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL での名前は RSA-PSK-ARIA128-GCM-SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x6F | TLS_RSA_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL での名前は RSA-PSK-ARIA256-GCM-SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x70 | TLS_ECDHE_PSK_WITH_ARIA_128_CBC_SHA256 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x71 | TLS_ECDHE_PSK_WITH_ARIA_256_CBC_SHA384 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x72 | TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は ECDHE-ECDSA-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x73 | TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は ECDHE-ECDSA-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x74 | TLS_ECDH_ECDSA_WITH_CAMELLIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x75 | TLS_ECDH_ECDSA_WITH_CAMELLIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x76 | TLS_ECDHE_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は ECDHE-RSA-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_ECDHE_RSA_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x77 | TLS_ECDHE_RSA_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は ECDHE-RSA-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_ECDHE_RSA_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x78 | TLS_ECDH_RSA_WITH_CAMELLIA_128_CBC_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x79 | TLS_ECDH_RSA_WITH_CAMELLIA_256_CBC_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7A | TLS_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_RSA_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7B | TLS_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_RSA_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7C | TLS_DHE_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7D | TLS_DHE_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_DHE_RSA_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7E | TLS_DH_RSA_WITH_CAMELLIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x7F | TLS_DH_RSA_WITH_CAMELLIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x80 | TLS_DHE_DSS_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x81 | TLS_DHE_DSS_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_DHE_DSS_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x82 | TLS_DH_DSS_WITH_CAMELLIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x83 | TLS_DH_DSS_WITH_CAMELLIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x84 | TLS_DH_anon_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_DH_ANON_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x85 | TLS_DH_anon_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_DH_ANON_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全でない。弱点:サーバーが認証されないため能動的な攻撃者によるなりすましが可能、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x86 | TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_ECDHE_ECDSA_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x87 | TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_ECDHE_ECDSA_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x88 | TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x89 | TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x8A | TLS_ECDHE_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_ECDHE_RSA_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x8B | TLS_ECDHE_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_ECDHE_RSA_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0x8C | TLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x8D | TLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x8E | TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_PSK_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x8F | TLS_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_PSK_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x90 | TLS_DHE_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_DHE_PSK_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x91 | TLS_DHE_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_DHE_PSK_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x92 | TLS_RSA_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS での名前は TLS_RSA_PSK_CAMELLIA_128_GCM_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x93 | TLS_RSA_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS での名前は TLS_RSA_PSK_CAMELLIA_256_GCM_SHA384 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x94 | TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は PSK-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_PSK_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x95 | TLS_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は PSK-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_PSK_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0x96 | TLS_DHE_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は DHE-PSK-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_DHE_PSK_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x97 | TLS_DHE_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は DHE-PSK-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_DHE_PSK_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x98 | TLS_RSA_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は RSA-PSK-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_RSA_PSK_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x99 | TLS_RSA_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は RSA-PSK-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_RSA_PSK_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)、前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x9A | TLS_ECDHE_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL での名前は ECDHE-PSK-CAMELLIA128-SHA256 です。 GnuTLS での名前は TLS_ECDHE_PSK_CAMELLIA_128_CBC_SHA256 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x9B | TLS_ECDHE_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL での名前は ECDHE-PSK-CAMELLIA256-SHA384 です。 GnuTLS での名前は TLS_ECDHE_PSK_CAMELLIA_256_CBC_SHA384 です。 | TLS 1.0, TLS 1.1, TLS 1.2 | ecdsa.com の評価:脆弱。弱点:MAC-then-encrypt 方式の CBC(Lucky Thirteen などのパディングオラクル攻撃の原因となる構成)。 | N |
0xC0,0x9C | TLS_RSA_WITH_AES_128_CCMOpenSSL での名前は AES128-CCM です。 GnuTLS での名前は TLS_RSA_AES_128_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x9D | TLS_RSA_WITH_AES_256_CCMOpenSSL での名前は AES256-CCM です。 GnuTLS での名前は TLS_RSA_AES_256_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xC0,0x9E | TLS_DHE_RSA_WITH_AES_128_CCMOpenSSL での名前は DHE-RSA-AES128-CCM です。 GnuTLS での名前は TLS_DHE_RSA_AES_128_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0x9F | TLS_DHE_RSA_WITH_AES_256_CCMOpenSSL での名前は DHE-RSA-AES256-CCM です。 GnuTLS での名前は TLS_DHE_RSA_AES_256_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0xA0 | TLS_RSA_WITH_AES_128_CCM_8OpenSSL での名前は AES128-CCM8 です。 GnuTLS での名前は TLS_RSA_AES_128_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xA1 | TLS_RSA_WITH_AES_256_CCM_8OpenSSL での名前は AES256-CCM8 です。 GnuTLS での名前は TLS_RSA_AES_256_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xA2 | TLS_DHE_RSA_WITH_AES_128_CCM_8OpenSSL での名前は DHE-RSA-AES128-CCM8 です。 GnuTLS での名前は TLS_DHE_RSA_AES_128_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xA3 | TLS_DHE_RSA_WITH_AES_256_CCM_8OpenSSL での名前は DHE-RSA-AES256-CCM8 です。 GnuTLS での名前は TLS_DHE_RSA_AES_256_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xA4 | TLS_PSK_WITH_AES_128_CCMOpenSSL での名前は PSK-AES128-CCM です。 GnuTLS での名前は TLS_PSK_AES_128_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0xA5 | TLS_PSK_WITH_AES_256_CCMOpenSSL での名前は PSK-AES256-CCM です。 GnuTLS での名前は TLS_PSK_AES_256_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC0,0xA6 | TLS_DHE_PSK_WITH_AES_128_CCMOpenSSL での名前は DHE-PSK-AES128-CCM です。 GnuTLS での名前は TLS_DHE_PSK_AES_128_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0xA7 | TLS_DHE_PSK_WITH_AES_256_CCMOpenSSL での名前は DHE-PSK-AES256-CCM です。 GnuTLS での名前は TLS_DHE_PSK_AES_256_CCM です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xC0,0xA8 | TLS_PSK_WITH_AES_128_CCM_8OpenSSL での名前は PSK-AES128-CCM8 です。 GnuTLS での名前は TLS_PSK_AES_128_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0xC0,0xA9 | TLS_PSK_WITH_AES_256_CCM_8OpenSSL での名前は PSK-AES256-CCM8 です。 GnuTLS での名前は TLS_PSK_AES_256_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0xC0,0xAA | TLS_PSK_DHE_WITH_AES_128_CCM_8OpenSSL での名前は DHE-PSK-AES128-CCM8 です。 GnuTLS での名前は TLS_DHE_PSK_AES_128_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xAB | TLS_PSK_DHE_WITH_AES_256_CCM_8OpenSSL での名前は DHE-PSK-AES256-CCM8 です。 GnuTLS での名前は TLS_DHE_PSK_AES_256_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている、IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | D |
0xC0,0xAC | TLS_ECDHE_ECDSA_WITH_AES_128_CCMOpenSSL での名前は ECDHE-ECDSA-AES128-CCM です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_128_CCM です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xAD | TLS_ECDHE_ECDSA_WITH_AES_256_CCMOpenSSL での名前は ECDHE-ECDSA-AES256-CCM です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_256_CCM です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xAE | TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8OpenSSL での名前は ECDHE-ECDSA-AES128-CCM8 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_128_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点:IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0xC0,0xAF | TLS_ECDHE_ECDSA_WITH_AES_256_CCM_8OpenSSL での名前は ECDHE-ECDSA-AES256-CCM8 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_AES_256_CCM_8 です。 | TLS 1.2 | ecdsa.com の評価:安全。弱点:IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0xC0,0xB0 | TLS_ECCPWD_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xB1 | TLS_ECCPWD_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xB2 | TLS_ECCPWD_WITH_AES_128_CCM_SHA256 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xB3 | TLS_ECCPWD_WITH_AES_256_CCM_SHA384 | TLS 1.2 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC0,0xB4 | TLS_SHA256_SHA256OpenSSL での名前は TLS_SHA256_SHA256 です。 | TLS 1.3 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC0,0xB5 | TLS_SHA384_SHA384OpenSSL での名前は TLS_SHA384_SHA384 です。 | TLS 1.3 | ecdsa.com の評価:安全でない。弱点:レコードが暗号化されない、IANA がこのスイートを非推奨としている。 | D |
0xC1,0x00 | TLS_GOSTR341112_256_WITH_KUZNYECHIK_CTR_OMACOpenSSL での名前は GOST2012-KUZNYECHIK-KUZNYECHIKOMAC です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC1,0x01 | TLS_GOSTR341112_256_WITH_MAGMA_CTR_OMACOpenSSL での名前は GOST2012-MAGMA-MAGMAOMAC です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC1,0x02 | TLS_GOSTR341112_256_WITH_28147_CNT_IMITGnuTLS での名前は TLS_GOSTR341112_256_28147_CNT_IMIT です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xC1,0x03 | TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_L | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC1,0x04 | TLS_GOSTR341112_256_WITH_MAGMA_MGM_L | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC1,0x05 | TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_S | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xC1,0x06 | TLS_GOSTR341112_256_WITH_MAGMA_MGM_S | TLS 1.3 | ecdsa.com の評価:安全。弱点は見つかりませんでした。 | N |
0xCA,0xCA | Reserved | — | N | |
0xCC,0xA8 | TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は ECDHE-RSA-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_ECDHE_RSA_CHACHA20_POLY1305 です。 NSS での名前は TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xCC,0xA9注記 | TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は ECDHE-ECDSA-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_ECDHE_ECDSA_CHACHA20_POLY1305 です。 NSS での名前は TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xCC,0xAA | TLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は DHE-RSA-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_DHE_RSA_CHACHA20_POLY1305 です。 NSS での名前は TLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xCC,0xAB | TLS_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は PSK-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_PSK_CHACHA20_POLY1305 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)。 | N |
0xCC,0xAC | TLS_ECDHE_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は ECDHE-PSK-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_ECDHE_PSK_CHACHA20_POLY1305 です。 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xCC,0xAD | TLS_DHE_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は DHE-PSK-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_DHE_PSK_CHACHA20_POLY1305 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:IANA がこのスイートを非推奨としている。 | D |
0xCC,0xAE | TLS_RSA_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL での名前は RSA-PSK-CHACHA20-POLY1305 です。 GnuTLS での名前は TLS_RSA_PSK_CHACHA20_POLY1305 です。 | TLS 1.2 | ecdsa.com の評価:脆弱。弱点:前方秘匿性がない(サーバー鍵が盗まれると、記録された過去の通信が復号される)、IANA がこのスイートを非推奨としている。 | D |
0xD0,0x01 | TLS_ECDHE_PSK_WITH_AES_128_GCM_SHA256 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xD0,0x02 | TLS_ECDHE_PSK_WITH_AES_256_GCM_SHA384 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xD0,0x03 | TLS_ECDHE_PSK_WITH_AES_128_CCM_8_SHA256 | TLS 1.2 | ecdsa.com の評価:安全。弱点:IANA が一般用途には推奨していない 8 バイトの認証タグ(CCM_8)。 | N |
0xD0,0x05 | TLS_ECDHE_PSK_WITH_AES_128_CCM_SHA256 | TLS 1.2 | ecdsa.com の評価:推奨。弱点は見つかりませんでした。 | Y |
0xDA,0xDA | Reserved | — | N | |
0xEA,0xEA | Reserved | — | N | |
0xFA,0xFA | Reserved | — | N |
| 範囲 | ステータス | 説明 |
|---|---|---|
| 0x001C–0x001D | reserved | Reserved to avoid conflicts with SSLv3 |
| 0x0047–0x004F | reserved | Reserved to avoid conflicts with deployed implementations |
| 0x0050–0x0058 | reserved | Reserved to avoid conflicts |
| 0x0059–0x005C | reserved | Reserved to avoid conflicts with deployed implementations |
| 0x005D–0x005F | unassigned | Unassigned |
| 0x0060–0x0066 | reserved | Reserved to avoid conflicts with widely deployed implementations |
| 0x0072–0x0083 | unassigned | Unassigned |
| 0x00C8–0x00FE | unassigned | Unassigned |
| 0x0100–0x09FF | unassigned | Unassigned |
| 0x0A00–0x0A09 | unassigned | Unassigned |
| 0x0A0B–0x0AFF | unassigned | Unassigned |
| 0x0B00–0x12FF | unassigned | Unassigned |
| 0x1300 | unassigned | Unassigned |
| 0x1308–0x13FF | unassigned | Unassigned |
| 0x1400–0x19FF | unassigned | Unassigned |
| 0x1A00–0x1A19 | unassigned | Unassigned |
| 0x1A1B–0x1AFF | unassigned | Unassigned |
| 0x1B00–0x29FF | unassigned | Unassigned |
| 0x2A00–0x2A29 | unassigned | Unassigned |
| 0x2A2B–0x2AFF | unassigned | Unassigned |
| 0x2B00–0x39FF | unassigned | Unassigned |
| 0x3A00–0x3A39 | unassigned | Unassigned |
| 0x3A3B–0x3AFF | unassigned | Unassigned |
| 0x3B00–0x49FF | unassigned | Unassigned |
| 0x4A00–0x4A49 | unassigned | Unassigned |
| 0x4A4B–0x4AFF | unassigned | Unassigned |
| 0x4B00–0x55FF | unassigned | Unassigned |
| 0x5601–0x56FF | unassigned | Unassigned |
| 0x5700–0x59FF | unassigned | Unassigned |
| 0x5A00–0x5A59 | unassigned | Unassigned |
| 0x5A5B–0x5AFF | unassigned | Unassigned |
| 0x5B00–0x69FF | unassigned | Unassigned |
| 0x6A00–0x6A69 | unassigned | Unassigned |
| 0x6A6B–0x6AFF | unassigned | Unassigned |
| 0x6B00–0x79FF | unassigned | Unassigned |
| 0x7A00–0x7A79 | unassigned | Unassigned |
| 0x7A7B–0x7AFF | unassigned | Unassigned |
| 0x7B00–0x89FF | unassigned | Unassigned |
| 0x8A00–0x8A89 | unassigned | Unassigned |
| 0x8A8B–0x8AFF | unassigned | Unassigned |
| 0x8B00–0x99FF | unassigned | Unassigned |
| 0x9A00–0x9A99 | unassigned | Unassigned |
| 0x9A9B–0x9AFF | unassigned | Unassigned |
| 0x9B00–0xA9FF | unassigned | Unassigned |
| 0xAA00–0xAAA9 | unassigned | Unassigned |
| 0xAAAB–0xAAFF | unassigned | Unassigned |
| 0xAB00–0xB9FF | unassigned | Unassigned |
| 0xBA00–0xBAB9 | unassigned | Unassigned |
| 0xBABB–0xBAFF | unassigned | Unassigned |
| 0xBB00–0xBFFF | unassigned | Unassigned |
| 0xC000 | unassigned | Unassigned |
| 0xC0B6–0xC0FF | unassigned | Unassigned |
| 0xC107–0xC1FF | unassigned | Unassigned |
| 0xC200–0xC9FF | unassigned | Unassigned |
| 0xCA00–0xCAC9 | unassigned | Unassigned |
| 0xCACB–0xCAFF | unassigned | Unassigned |
| 0xCB00–0xCBFF | unassigned | Unassigned |
| 0xCC00–0xCCA7 | unassigned | Unassigned |
| 0xCCAF–0xCCFF | unassigned | Unassigned |
| 0xCD00–0xCFFF | unassigned | Unassigned |
| 0xD000 | unassigned | Unassigned |
| 0xD004 | unassigned | Unassigned |
| 0xD006–0xD0FF | unassigned | Unassigned |
| 0xD100–0xD9FF | unassigned | Unassigned |
| 0xDA00–0xDAD9 | unassigned | Unassigned |
| 0xDADB–0xDAFF | unassigned | Unassigned |
| 0xDB00–0xE9FF | unassigned | Unassigned |
| 0xEA00–0xEAE9 | unassigned | Unassigned |
| 0xEAEB–0xEAFF | unassigned | Unassigned |
| 0xEB00–0xF9FF | unassigned | Unassigned |
| 0xFA00–0xFAC9 | unassigned | Unassigned |
| 0xFAFB–0xFAFF | unassigned | Unassigned |
| 0xFB00–0xFDFF | unassigned | Unassigned |
| 0xFE00–0xFEFD | unassigned | Unassigned |
| 0xFEFE–0xFEFF | reserved | Reserved to avoid conflicts with widely deployed implementations |
| 0xFF00–0xFFFF | private | Reserved for Private Use |
出典:Transport Layer Security (TLS) Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0, Apache-2.0, LGPL-2.1-or-later, MPL-2.0。 TLS Cipher Suites · OpenSSL openssl-4.0.3 include/openssl/tls1.h · OpenSSL openssl-4.0.3 include/openssl/ssl3.h · OpenSSL openssl-4.0.3 ssl/s3_lib.c · GnuTLS 3.8.13 lib/algorithms/ciphersuites.c · NSS NSS_3_131_RTM lib/ssl/sslproto.h · NSS NSS_3_131_RTM lib/ssl/sslinfo.c
最初のハンドシェイクが完了する前の接続に置かれる、仮のスイートです。鍵交換も認証も保護もありません。
TLS_NULL_WITH_NULL_NULL(0x00,0x00)は TLS 1.2 接続の初期状態を表します(RFC 5246 §6.1)。ネゴシエートされることはなく、これを選択するサーバーには深刻なバグがあります。
SHA-1 と RSA 鍵輸送を使う RC4 のスイートです。かつては BEAST への対策として広く選ばれましたが、現在は RFC 7465 で禁止されています。
RC4 は 2011〜2013年の CBC への攻撃を受けないため、一時期はその理由で推奨されていました。しかし、キーストリームの偏りにより、Cookie のように繰り返し送信される平文を攻撃者が復元できてしまいます。RFC 7465 §2 は、クライアントは ClientHello に RC4 のスイートを含めてはいけない(MUST NOT)、サーバーはそれを選択してはいけない(MUST NOT)と定めています。
TLS 1.1 で実装必須とされたスイートです。ブロック長が 64 ビットのため、Sweet32 の誕生日攻撃に対して脆弱になりました。
RFC 4346 §9 は、TLS 1.1 の実装に TLS_RSA_WITH_3DES_EDE_CBC_SHA(OpenSSL:DES-CBC3-SHA)のサポートを求めていました。トリプル DES のブロックは 64 ビットなので、1 つの鍵で約 2^32 ブロックを処理すると、衝突から平文が漏れます。2016年の Sweet32 攻撃は、この方法で長時間続く接続から HTTP の Cookie を復元しました。
前方秘匿性もありません。最近のライブラリはデフォルトで無効にしており、IANA は非推奨としています。
TLS 1.2 で実装必須とされたスイートです。前方秘匿性がなく、CBC を使います。現在は RFC 10015 で禁止されています。
RFC 5246 §9 はすべての TLS 1.2 実装に TLS_RSA_WITH_AES_128_CBC_SHA(OpenSSL:AES128-SHA)のサポートを求めていたため、多くの古いクライアントにとって最後の手段となるスイートです。RSA 鍵輸送では、クライアントがサーバー証明書の鍵でプリマスターシークレットを暗号化します。そのため、後でその鍵を入手した者は誰でも、記録されたすべてのセッションを復号できます。
MAC-then-encrypt 方式の CBC により、Lucky Thirteen などのパディングオラクル攻撃を受けやすくなっていました。現在、RFC 10015 §4 は、TLS 1.2 の RSA 鍵交換スイートについて、クライアントは提示してはいけない(MUST NOT)、サーバーは選択してはいけない(MUST NOT)と定めています。
実在のスイートではなくシグナリング用の値で、クライアントが安全な再ネゴシエーションに対応していることを示します(RFC 5746)。
クライアントは TLS_EMPTY_RENEGOTIATION_INFO_SCSV(0x00,0xFF)を暗号スイートのリストに入れ、拡張を送らずに安全な再ネゴシエーションへの対応を通知します。一部のサーバーが拡張を正しく処理できなかったため、RFC 5746 §3.3 で導入されました。この値は「ネゴシエートできない」ものです。再ネゴシエーションの修正により、攻撃者がクライアントの再ネゴシエートされたセッションの前に自分のデータを差し込む 2009年の攻撃が防がれました。
すべての TLS 1.3 実装がサポートしなければならない暗号スイートです。GCM モードの AES-128 と、鍵スケジュール用の SHA-256 を使います。
RFC 8446 §9.1 は TLS 1.3 で TLS_AES_128_GCM_SHA256 の実装を必須とし、その後継である RFC 9846 もこの要件を引き継いでいます。TLS 1.3 のスイートが指定するのは AEAD と HKDF のハッシュだけで、鍵交換(たとえば X25519MLKEM768)と署名(たとえば ecdsa_secp256r1_sha256)は別の拡張でネゴシエートされます。
OpenSSL では TLS 1.3 のスイートを -ciphersuites で設定し、TLS 1.2 で使う -cipher 文字列では設定しません。そのため、サーバーの暗号リストを変更しても TLS 1.3 には影響しないことがよくあります。
SHA-384 を使う AES-256-GCM で、実装がサポートすべき(SHOULD)と RFC 8446 が定めている 2 つの TLS 1.3 スイートの 1 つです。
TLS_AES_256_GCM_SHA384 は、256 ビットの AES 鍵と鍵スケジュールの SHA-384 を組み合わせます。RFC 8446 §9.1 では、TLS_CHACHA20_POLY1305_SHA256 とともに SHOULD として挙げられています。ほとんどのサーバーが提供しており、CNSA に沿ったプロファイルでは必須です。
量子コンピューターを使う攻撃者に対しても、グローバーのアルゴリズムで AES の実効鍵長はせいぜい半分になるだけなので、AES-256 には十分な余裕があります。こうした攻撃は並列化しにくいため、NIST は AES-128 でも十分だとしています。
ChaCha20-Poly1305 は、AES 命令を持たないデバイスでもソフトウェアで高速に動作する TLS 1.3 スイートです。
TLS_CHACHA20_POLY1305_SHA256 は、ChaCha20 ストリーム暗号と Poly1305 メッセージ認証コードを使います(RFC 8439)。ハードウェアの支援がなくても定数時間で動作するため、AES 命令を持たないモバイルデバイスで優先されるスイートになりました。クライアントがこれを先頭に挙げた場合、サーバーはその選択に従うのが一般的です。
RFC 8446 §9.1 は、TLS 1.3 の実装がこれをサポートすべき(SHOULD)としています。TLS 1.2 で対応するスイートは TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256 と TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256 です(RFC 7905)。
TLS 1.3 の AES-128-CCM で、AES-CCM 用のハードウェアをすでに備えた、リソースの限られたデバイスで主に使われます。
CCM は AES-CTR による暗号化と AES-CBC-MAC を組み合わせたもので、IoT の無線通信でよく使われます。IANA は TLS_AES_128_CCM_SHA256 を推奨としていますが、8 バイトのタグを使う TLS_AES_128_CCM_8_SHA256 は一般用途には推奨していません。
クライアントがより低いプロトコルバージョンで再試行していることをサーバーに伝える、シグナリング用の値です(RFC 7507)。
失敗したハンドシェイクを古いプロトコルバージョンで再試行するクライアントは、攻撃者によって SSL 3.0 まで引き下げられるおそれがあり、2014年には POODLE がこれを悪用しました。クライアントはこうした再試行の際に TLS_FALLBACK_SCSV(0x56,0x00)を送ります。クライアントが提示したバージョンより高いバージョンに対応するサーバーは、処理を続けずに inappropriate_fallback で中断します。TLS 1.3 では ServerHello.random にダウングレード検出用のセンチネルが入るため、TLS 1.3 同士ではこの仕組みは不要です。
ECDSA 証明書で一般的な TLS 1.2 スイートです。ECDHE による鍵交換、ECDSA による認証、AES-128-GCM を組み合わせます。
TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256(RFC 5289)は、ECDHE の一時鍵によって前方秘匿性を実現し、通常は P-256 の ECDSA 証明書でサーバーを認証します。サーバーが ECDSA 証明書を持つ場合に、ブラウザーが優先する TLS 1.2 スイートです。
OpenSSL の暗号リスト文字列では ECDHE-ECDSA-AES128-GCM-SHA256 です。RSA 証明書しか持たないサーバーは、このスイートをネゴシエートできません。TLS 1.2 のスイートの認証部分は、証明書の鍵の種類と一致しなければならないからです。
HTTP/2 が必須とする TLS 1.2 スイートです。ECDHE による鍵交換、RSA による認証、AES-128-GCM を組み合わせます。
RFC 9113 §9.2.2 は、TLS 1.2 を使う HTTP/2 の環境に、P-256 曲線での TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 のサポートを求めています。これにより、TLS 1.2 に対する HTTP/2 の制限に従うクライアントとサーバーの間には、必ず共通のスイートが存在します。
OpenSSL での名前は ECDHE-RSA-AES128-GCM-SHA256 です。名前に RSA とありますが、RSA 鍵はハンドシェイクに署名するだけで、セッション鍵は一時的な ECDHE 交換から得られます。そのため、このスイートには前方秘匿性があります。
最も一般的な TLS 1.2 スイートの 256 ビット版です。ECDHE、RSA による認証、AES-256-GCM、SHA-384 の PRF を組み合わせます。
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384(RFC 5289)は、RSA 証明書を持つほぼすべての TLS 1.2 サーバーが提供しています。名前にある SHA384 は TLS 1.2 の PRF のハッシュを決めるもので、GCM 自体には別の MAC は必要ありません。
ECDHE 鍵交換と ECDSA 証明書を使う、TLS 1.2 の ChaCha20-Poly1305 です(RFC 7905)。
2016年に TLS 1.2 に追加されたこのスイートにより、まだ TLS 1.3 を提供できないサーバーでも、ソフトウェア実装に向いた AEAD である ChaCha20-Poly1305 を使えるようになりました。IANA はこれを推奨としています。OpenSSL での名前は ECDHE-ECDSA-CHACHA20-POLY1305 です。