跳到主要内容
ecdsa.com
TLS

TLS 密码套件及其 OpenSSL、GnuTLS 和 NSS 名称

本页收录 IANA TLS 注册表中的每一个密码套件,列出其码点、在 OpenSSL、GnuTLS 和 NSS 中的名称、适用的协议版本,以及逐一说明弱套件问题所在的评级。

显示 372 项中的 372 项

TLS 密码套件 · 372 个条目

IANA TLS 注册表中的全部 372 个密码套件,附 OpenSSL、GnuTLS 和 NSS 中的名称、密钥交换、加密算法、MAC 和安全评级。

值名称协议版本评级推荐
0x00,0x00说明TLS_NULL_WITH_NULL_NULLTLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、不验证服务器身份(主动攻击者可以冒充服务器)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x01TLS_RSA_WITH_NULL_MD5OpenSSL 中称为 NULL-MD5。 GnuTLS 中称为 TLS_RSA_NULL_MD5。 NSS 中称为 TLS_RSA_WITH_NULL_MD5。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x02TLS_RSA_WITH_NULL_SHAOpenSSL 中称为 NULL-SHA。 GnuTLS 中称为 TLS_RSA_NULL_SHA1。 NSS 中称为 TLS_RSA_WITH_NULL_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x03TLS_RSA_EXPORT_WITH_RC4_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x04TLS_RSA_WITH_RC4_128_MD5OpenSSL 中称为 RC4-MD5。 GnuTLS 中称为 TLS_RSA_ARCFOUR_128_MD5。 NSS 中称为 TLS_RSA_WITH_RC4_128_MD5。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x05说明TLS_RSA_WITH_RC4_128_SHAOpenSSL 中称为 RC4-SHA。 GnuTLS 中称为 TLS_RSA_ARCFOUR_128_SHA1。 NSS 中称为 TLS_RSA_WITH_RC4_128_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x06TLS_RSA_EXPORT_WITH_RC2_CBC_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、使用 40 位密钥的 RC2、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x07TLS_RSA_WITH_IDEA_CBC_SHAOpenSSL 中称为 IDEA-CBC-SHA。TLS 1.0, TLS 1.1ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x08TLS_RSA_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x09TLS_RSA_WITH_DES_CBC_SHANSS 中称为 TLS_RSA_WITH_DES_CBC_SHA。TLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0A说明TLS_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 DES-CBC3-SHA。 GnuTLS 中称为 TLS_RSA_3DES_EDE_CBC_SHA1。 NSS 中称为 TLS_RSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0BTLS_DH_DSS_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0CTLS_DH_DSS_WITH_DES_CBC_SHATLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0DTLS_DH_DSS_WITH_3DES_EDE_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0ETLS_DH_RSA_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x0FTLS_DH_RSA_WITH_DES_CBC_SHATLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x10TLS_DH_RSA_WITH_3DES_EDE_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x11TLS_DHE_DSS_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x12TLS_DHE_DSS_WITH_DES_CBC_SHANSS 中称为 TLS_DHE_DSS_WITH_DES_CBC_SHA。TLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x13TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 DHE-DSS-DES-CBC3-SHA。 GnuTLS 中称为 TLS_DHE_DSS_3DES_EDE_CBC_SHA1。 NSS 中称为 TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x14TLS_DHE_RSA_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x15TLS_DHE_RSA_WITH_DES_CBC_SHANSS 中称为 TLS_DHE_RSA_WITH_DES_CBC_SHA。TLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x16TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 DHE-RSA-DES-CBC3-SHA。 GnuTLS 中称为 TLS_DHE_RSA_3DES_EDE_CBC_SHA1。 NSS 中称为 TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x17TLS_DH_anon_EXPORT_WITH_RC4_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x18TLS_DH_anon_WITH_RC4_128_MD5OpenSSL 中称为 ADH-RC4-MD5。 GnuTLS 中称为 TLS_DH_ANON_ARCFOUR_128_MD5。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x19TLS_DH_anon_EXPORT_WITH_DES40_CBC_SHATLS 1.0ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x1ATLS_DH_anon_WITH_DES_CBC_SHATLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x1BTLS_DH_anon_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 ADH-DES-CBC3-SHA。 GnuTLS 中称为 TLS_DH_ANON_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x1ETLS_KRB5_WITH_DES_CBC_SHATLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x1FTLS_KRB5_WITH_3DES_EDE_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x20TLS_KRB5_WITH_RC4_128_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x21TLS_KRB5_WITH_IDEA_CBC_SHATLS 1.0, TLS 1.1ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x22TLS_KRB5_WITH_DES_CBC_MD5TLS 1.0, TLS 1.1ecdsa.com 评级:不安全。弱点:单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x23TLS_KRB5_WITH_3DES_EDE_CBC_MD5TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x24TLS_KRB5_WITH_RC4_128_MD5TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x25TLS_KRB5_WITH_IDEA_CBC_MD5TLS 1.0, TLS 1.1ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x26TLS_KRB5_EXPORT_WITH_DES_CBC_40_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x27TLS_KRB5_EXPORT_WITH_RC2_CBC_40_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、使用 40 位密钥的 RC2、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x28TLS_KRB5_EXPORT_WITH_RC4_40_SHATLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x29TLS_KRB5_EXPORT_WITH_DES_CBC_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、单 DES(56 位密钥可被穷举搜索找出)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x2ATLS_KRB5_EXPORT_WITH_RC2_CBC_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、使用 40 位密钥的 RC2、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x2BTLS_KRB5_EXPORT_WITH_RC4_40_MD5TLS 1.0ecdsa.com 评级:不安全。弱点:20 世纪 90 年代被刻意削弱的出口级密码(FREAK、Logjam)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、HMAC-MD5、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x2CTLS_PSK_WITH_NULL_SHAOpenSSL 中称为 PSK-NULL-SHA。 GnuTLS 中称为 TLS_PSK_NULL_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x2DTLS_DHE_PSK_WITH_NULL_SHAOpenSSL 中称为 DHE-PSK-NULL-SHA。 GnuTLS 中称为 TLS_DHE_PSK_NULL_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0x00,0x2ETLS_RSA_PSK_WITH_NULL_SHAOpenSSL 中称为 RSA-PSK-NULL-SHA。 GnuTLS 中称为 TLS_RSA_PSK_NULL_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x2F说明TLS_RSA_WITH_AES_128_CBC_SHAOpenSSL 中称为 AES128-SHA。 GnuTLS 中称为 TLS_RSA_AES_128_CBC_SHA1。 NSS 中称为 TLS_RSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x30TLS_DH_DSS_WITH_AES_128_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x31TLS_DH_RSA_WITH_AES_128_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x32TLS_DHE_DSS_WITH_AES_128_CBC_SHAOpenSSL 中称为 DHE-DSS-AES128-SHA。 GnuTLS 中称为 TLS_DHE_DSS_AES_128_CBC_SHA1。 NSS 中称为 TLS_DHE_DSS_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x33TLS_DHE_RSA_WITH_AES_128_CBC_SHAOpenSSL 中称为 DHE-RSA-AES128-SHA。 GnuTLS 中称为 TLS_DHE_RSA_AES_128_CBC_SHA1。 NSS 中称为 TLS_DHE_RSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x34TLS_DH_anon_WITH_AES_128_CBC_SHAOpenSSL 中称为 ADH-AES128-SHA。 GnuTLS 中称为 TLS_DH_ANON_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x35TLS_RSA_WITH_AES_256_CBC_SHAOpenSSL 中称为 AES256-SHA。 GnuTLS 中称为 TLS_RSA_AES_256_CBC_SHA1。 NSS 中称为 TLS_RSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x36TLS_DH_DSS_WITH_AES_256_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x37TLS_DH_RSA_WITH_AES_256_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x38TLS_DHE_DSS_WITH_AES_256_CBC_SHAOpenSSL 中称为 DHE-DSS-AES256-SHA。 GnuTLS 中称为 TLS_DHE_DSS_AES_256_CBC_SHA1。 NSS 中称为 TLS_DHE_DSS_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x39TLS_DHE_RSA_WITH_AES_256_CBC_SHAOpenSSL 中称为 DHE-RSA-AES256-SHA。 GnuTLS 中称为 TLS_DHE_RSA_AES_256_CBC_SHA1。 NSS 中称为 TLS_DHE_RSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x3ATLS_DH_anon_WITH_AES_256_CBC_SHAOpenSSL 中称为 ADH-AES256-SHA。 GnuTLS 中称为 TLS_DH_ANON_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x3BTLS_RSA_WITH_NULL_SHA256OpenSSL 中称为 NULL-SHA256。 GnuTLS 中称为 TLS_RSA_NULL_SHA256。 NSS 中称为 TLS_RSA_WITH_NULL_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x3CTLS_RSA_WITH_AES_128_CBC_SHA256OpenSSL 中称为 AES128-SHA256。 GnuTLS 中称为 TLS_RSA_AES_128_CBC_SHA256。 NSS 中称为 TLS_RSA_WITH_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x3DTLS_RSA_WITH_AES_256_CBC_SHA256OpenSSL 中称为 AES256-SHA256。 GnuTLS 中称为 TLS_RSA_AES_256_CBC_SHA256。 NSS 中称为 TLS_RSA_WITH_AES_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x3ETLS_DH_DSS_WITH_AES_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x3FTLS_DH_RSA_WITH_AES_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x40TLS_DHE_DSS_WITH_AES_128_CBC_SHA256OpenSSL 中称为 DHE-DSS-AES128-SHA256。 GnuTLS 中称为 TLS_DHE_DSS_AES_128_CBC_SHA256。 NSS 中称为 TLS_DHE_DSS_WITH_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x41TLS_RSA_WITH_CAMELLIA_128_CBC_SHAOpenSSL 中称为 CAMELLIA128-SHA。 GnuTLS 中称为 TLS_RSA_CAMELLIA_128_CBC_SHA1。 NSS 中称为 TLS_RSA_WITH_CAMELLIA_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x42TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x43TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x44TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHAOpenSSL 中称为 DHE-DSS-CAMELLIA128-SHA。 GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_128_CBC_SHA1。 NSS 中称为 TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x45TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHAOpenSSL 中称为 DHE-RSA-CAMELLIA128-SHA。 GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_128_CBC_SHA1。 NSS 中称为 TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x46TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHAOpenSSL 中称为 ADH-CAMELLIA128-SHA。 GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x67TLS_DHE_RSA_WITH_AES_128_CBC_SHA256OpenSSL 中称为 DHE-RSA-AES128-SHA256。 GnuTLS 中称为 TLS_DHE_RSA_AES_128_CBC_SHA256。 NSS 中称为 TLS_DHE_RSA_WITH_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x68TLS_DH_DSS_WITH_AES_256_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x69TLS_DH_RSA_WITH_AES_256_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x6ATLS_DHE_DSS_WITH_AES_256_CBC_SHA256OpenSSL 中称为 DHE-DSS-AES256-SHA256。 GnuTLS 中称为 TLS_DHE_DSS_AES_256_CBC_SHA256。 NSS 中称为 TLS_DHE_DSS_WITH_AES_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x6BTLS_DHE_RSA_WITH_AES_256_CBC_SHA256OpenSSL 中称为 DHE-RSA-AES256-SHA256。 GnuTLS 中称为 TLS_DHE_RSA_AES_256_CBC_SHA256。 NSS 中称为 TLS_DHE_RSA_WITH_AES_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x6CTLS_DH_anon_WITH_AES_128_CBC_SHA256OpenSSL 中称为 ADH-AES128-SHA256。 GnuTLS 中称为 TLS_DH_ANON_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x6DTLS_DH_anon_WITH_AES_256_CBC_SHA256OpenSSL 中称为 ADH-AES256-SHA256。 GnuTLS 中称为 TLS_DH_ANON_AES_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x6ETLS_ASCONAEAD128_ASCONHASH256TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0x6FTLS_ASCONAEAD128_SHA256TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0x70TLS_AES_128_GCM_ASCONHASH256TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0x71TLS_AES_128_CCM_ASCONHASH256TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0x84TLS_RSA_WITH_CAMELLIA_256_CBC_SHAOpenSSL 中称为 CAMELLIA256-SHA。 GnuTLS 中称为 TLS_RSA_CAMELLIA_256_CBC_SHA1。 NSS 中称为 TLS_RSA_WITH_CAMELLIA_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x85TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x86TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x87TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHAOpenSSL 中称为 DHE-DSS-CAMELLIA256-SHA。 GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_256_CBC_SHA1。 NSS 中称为 TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x88TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHAOpenSSL 中称为 DHE-RSA-CAMELLIA256-SHA。 GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_256_CBC_SHA1。 NSS 中称为 TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x89TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHAOpenSSL 中称为 ADH-CAMELLIA256-SHA。 GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x8ATLS_PSK_WITH_RC4_128_SHAOpenSSL 中称为 PSK-RC4-SHA。 GnuTLS 中称为 TLS_PSK_ARCFOUR_128_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x8BTLS_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 PSK-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_PSK_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x8CTLS_PSK_WITH_AES_128_CBC_SHAOpenSSL 中称为 PSK-AES128-CBC-SHA。 GnuTLS 中称为 TLS_PSK_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x8DTLS_PSK_WITH_AES_256_CBC_SHAOpenSSL 中称为 PSK-AES256-CBC-SHA。 GnuTLS 中称为 TLS_PSK_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0x8ETLS_DHE_PSK_WITH_RC4_128_SHAOpenSSL 中称为 DHE-PSK-RC4-SHA。 GnuTLS 中称为 TLS_DHE_PSK_ARCFOUR_128_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)和IANA 将该套件标记为不建议使用。D
0x00,0x8FTLS_DHE_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 DHE-PSK-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_DHE_PSK_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x90TLS_DHE_PSK_WITH_AES_128_CBC_SHAOpenSSL 中称为 DHE-PSK-AES128-CBC-SHA。 GnuTLS 中称为 TLS_DHE_PSK_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x91TLS_DHE_PSK_WITH_AES_256_CBC_SHAOpenSSL 中称为 DHE-PSK-AES256-CBC-SHA。 GnuTLS 中称为 TLS_DHE_PSK_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x92TLS_RSA_PSK_WITH_RC4_128_SHAOpenSSL 中称为 RSA-PSK-RC4-SHA。 GnuTLS 中称为 TLS_RSA_PSK_ARCFOUR_128_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x93TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 RSA-PSK-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_RSA_PSK_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x94TLS_RSA_PSK_WITH_AES_128_CBC_SHAOpenSSL 中称为 RSA-PSK-AES128-CBC-SHA。 GnuTLS 中称为 TLS_RSA_PSK_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x95TLS_RSA_PSK_WITH_AES_256_CBC_SHAOpenSSL 中称为 RSA-PSK-AES256-CBC-SHA。 GnuTLS 中称为 TLS_RSA_PSK_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x96TLS_RSA_WITH_SEED_CBC_SHAOpenSSL 中称为 SEED-SHA。 NSS 中称为 TLS_RSA_WITH_SEED_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x97TLS_DH_DSS_WITH_SEED_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x98TLS_DH_RSA_WITH_SEED_CBC_SHATLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x99TLS_DHE_DSS_WITH_SEED_CBC_SHAOpenSSL 中称为 DHE-DSS-SEED-SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x9ATLS_DHE_RSA_WITH_SEED_CBC_SHAOpenSSL 中称为 DHE-RSA-SEED-SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0x9BTLS_DH_anon_WITH_SEED_CBC_SHAOpenSSL 中称为 ADH-SEED-SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x9CTLS_RSA_WITH_AES_128_GCM_SHA256OpenSSL 中称为 AES128-GCM-SHA256。 GnuTLS 中称为 TLS_RSA_AES_128_GCM_SHA256。 NSS 中称为 TLS_RSA_WITH_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x9DTLS_RSA_WITH_AES_256_GCM_SHA384OpenSSL 中称为 AES256-GCM-SHA384。 GnuTLS 中称为 TLS_RSA_AES_256_GCM_SHA384。 NSS 中称为 TLS_RSA_WITH_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0x9ETLS_DHE_RSA_WITH_AES_128_GCM_SHA256OpenSSL 中称为 DHE-RSA-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_DHE_RSA_AES_128_GCM_SHA256。 NSS 中称为 TLS_DHE_RSA_WITH_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0x9FTLS_DHE_RSA_WITH_AES_256_GCM_SHA384OpenSSL 中称为 DHE-RSA-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_DHE_RSA_AES_256_GCM_SHA384。 NSS 中称为 TLS_DHE_RSA_WITH_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0xA0TLS_DH_RSA_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA1TLS_DH_RSA_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA2TLS_DHE_DSS_WITH_AES_128_GCM_SHA256OpenSSL 中称为 DHE-DSS-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_DHE_DSS_AES_128_GCM_SHA256。 NSS 中称为 TLS_DHE_DSS_WITH_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0xA3TLS_DHE_DSS_WITH_AES_256_GCM_SHA384OpenSSL 中称为 DHE-DSS-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_DHE_DSS_AES_256_GCM_SHA384。 NSS 中称为 TLS_DHE_DSS_WITH_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0xA4TLS_DH_DSS_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA5TLS_DH_DSS_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA6TLS_DH_anon_WITH_AES_128_GCM_SHA256OpenSSL 中称为 ADH-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_DH_ANON_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA7TLS_DH_anon_WITH_AES_256_GCM_SHA384OpenSSL 中称为 ADH-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_DH_ANON_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xA8TLS_PSK_WITH_AES_128_GCM_SHA256OpenSSL 中称为 PSK-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_PSK_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0xA9TLS_PSK_WITH_AES_256_GCM_SHA384OpenSSL 中称为 PSK-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_PSK_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0xAATLS_DHE_PSK_WITH_AES_128_GCM_SHA256OpenSSL 中称为 DHE-PSK-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_DHE_PSK_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0xABTLS_DHE_PSK_WITH_AES_256_GCM_SHA384OpenSSL 中称为 DHE-PSK-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_DHE_PSK_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0x00,0xACTLS_RSA_PSK_WITH_AES_128_GCM_SHA256OpenSSL 中称为 RSA-PSK-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_RSA_PSK_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xADTLS_RSA_PSK_WITH_AES_256_GCM_SHA384OpenSSL 中称为 RSA-PSK-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_RSA_PSK_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xAETLS_PSK_WITH_AES_128_CBC_SHA256OpenSSL 中称为 PSK-AES128-CBC-SHA256。 GnuTLS 中称为 TLS_PSK_AES_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0xAFTLS_PSK_WITH_AES_256_CBC_SHA384OpenSSL 中称为 PSK-AES256-CBC-SHA384。 GnuTLS 中称为 TLS_PSK_AES_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0x00,0xB0TLS_PSK_WITH_NULL_SHA256OpenSSL 中称为 PSK-NULL-SHA256。 GnuTLS 中称为 TLS_PSK_NULL_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xB1TLS_PSK_WITH_NULL_SHA384OpenSSL 中称为 PSK-NULL-SHA384。 GnuTLS 中称为 TLS_PSK_NULL_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xB2TLS_DHE_PSK_WITH_AES_128_CBC_SHA256OpenSSL 中称为 DHE-PSK-AES128-CBC-SHA256。 GnuTLS 中称为 TLS_DHE_PSK_AES_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xB3TLS_DHE_PSK_WITH_AES_256_CBC_SHA384OpenSSL 中称为 DHE-PSK-AES256-CBC-SHA384。 GnuTLS 中称为 TLS_DHE_PSK_AES_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xB4TLS_DHE_PSK_WITH_NULL_SHA256OpenSSL 中称为 DHE-PSK-NULL-SHA256。 GnuTLS 中称为 TLS_DHE_PSK_NULL_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0x00,0xB5TLS_DHE_PSK_WITH_NULL_SHA384OpenSSL 中称为 DHE-PSK-NULL-SHA384。 GnuTLS 中称为 TLS_DHE_PSK_NULL_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0x00,0xB6TLS_RSA_PSK_WITH_AES_128_CBC_SHA256OpenSSL 中称为 RSA-PSK-AES128-CBC-SHA256。 GnuTLS 中称为 TLS_RSA_PSK_AES_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xB7TLS_RSA_PSK_WITH_AES_256_CBC_SHA384OpenSSL 中称为 RSA-PSK-AES256-CBC-SHA384。 GnuTLS 中称为 TLS_RSA_PSK_AES_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xB8TLS_RSA_PSK_WITH_NULL_SHA256OpenSSL 中称为 RSA-PSK-NULL-SHA256。 GnuTLS 中称为 TLS_RSA_PSK_NULL_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xB9TLS_RSA_PSK_WITH_NULL_SHA384OpenSSL 中称为 RSA-PSK-NULL-SHA384。 GnuTLS 中称为 TLS_RSA_PSK_NULL_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xBATLS_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_RSA_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xBBTLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xBCTLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xBDTLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 DHE-DSS-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xBETLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 DHE-RSA-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xBFTLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 ADH-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xC0TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256OpenSSL 中称为 CAMELLIA256-SHA256。 GnuTLS 中称为 TLS_RSA_CAMELLIA_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xC1TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xC2TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xC3TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA256OpenSSL 中称为 DHE-DSS-CAMELLIA256-SHA256。 GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xC4TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256OpenSSL 中称为 DHE-RSA-CAMELLIA256-SHA256。 GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0x00,0xC5TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA256OpenSSL 中称为 ADH-CAMELLIA256-SHA256。 GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_256_CBC_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0x00,0xC6TLS_SM4_GCM_SM3OpenSSL 中称为 TLS_SM4_GCM_SM3。TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0xC7TLS_SM4_CCM_SM3OpenSSL 中称为 TLS_SM4_CCM_SM3。TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x00,0xFF说明TLS_EMPTY_RENEGOTIATION_INFO_SCSV—N
0x0A,0x0AReserved—N
0x13,0x01说明TLS_AES_128_GCM_SHA256OpenSSL 中称为 TLS_AES_128_GCM_SHA256。 GnuTLS 中称为 TLS_AES_128_GCM_SHA256。 NSS 中称为 TLS_AES_128_GCM_SHA256。TLS 1.3ecdsa.com 评级:推荐。未发现弱点。Y
0x13,0x02说明TLS_AES_256_GCM_SHA384OpenSSL 中称为 TLS_AES_256_GCM_SHA384。 GnuTLS 中称为 TLS_AES_256_GCM_SHA384。 NSS 中称为 TLS_AES_256_GCM_SHA384。TLS 1.3ecdsa.com 评级:推荐。未发现弱点。Y
0x13,0x03说明TLS_CHACHA20_POLY1305_SHA256OpenSSL 中称为 TLS_CHACHA20_POLY1305_SHA256。 GnuTLS 中称为 TLS_CHACHA20_POLY1305_SHA256。 NSS 中称为 TLS_CHACHA20_POLY1305_SHA256。TLS 1.3ecdsa.com 评级:推荐。未发现弱点。Y
0x13,0x04说明TLS_AES_128_CCM_SHA256OpenSSL 中称为 TLS_AES_128_CCM_SHA256。 GnuTLS 中称为 TLS_AES_128_CCM_SHA256。TLS 1.3ecdsa.com 评级:推荐。未发现弱点。Y
0x13,0x05TLS_AES_128_CCM_8_SHA256OpenSSL 中称为 TLS_AES_128_CCM_8_SHA256。 GnuTLS 中称为 TLS_AES_128_CCM_8_SHA256。TLS 1.3ecdsa.com 评级:安全。弱点:8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0x13,0x06TLS_AEGIS_256_SHA512TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x13,0x07TLS_AEGIS_128L_SHA256TLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0x1A,0x1AReserved—N
0x2A,0x2AReserved—N
0x3A,0x3AReserved—N
0x4A,0x4AReserved—N
0x56,0x00说明TLS_FALLBACK_SCSV—N
0x5A,0x5AReserved—N
0x6A,0x6AReserved—N
0x7A,0x7AReserved—N
0x8A,0x8AReserved—N
0x9A,0x9AReserved—N
0xAA,0xAAReserved—N
0xBA,0xBAReserved—N
0xC0,0x01TLS_ECDH_ECDSA_WITH_NULL_SHANSS 中称为 TLS_ECDH_ECDSA_WITH_NULL_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x02TLS_ECDH_ECDSA_WITH_RC4_128_SHANSS 中称为 TLS_ECDH_ECDSA_WITH_RC4_128_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x03TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHANSS 中称为 TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x04TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHANSS 中称为 TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x05TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHANSS 中称为 TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x06TLS_ECDHE_ECDSA_WITH_NULL_SHAOpenSSL 中称为 ECDHE-ECDSA-NULL-SHA。 GnuTLS 中称为 TLS_ECDHE_ECDSA_NULL_SHA1。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_NULL_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0x07TLS_ECDHE_ECDSA_WITH_RC4_128_SHAOpenSSL 中称为 ECDHE-ECDSA-RC4-SHA。 GnuTLS 中称为 TLS_ECDHE_ECDSA_ARCFOUR_128_SHA1。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_RC4_128_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)和IANA 将该套件标记为不建议使用。D
0xC0,0x08TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 ECDHE-ECDSA-DES-CBC3-SHA。 GnuTLS 中称为 TLS_ECDHE_ECDSA_3DES_EDE_CBC_SHA1。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x09TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHAOpenSSL 中称为 ECDHE-ECDSA-AES128-SHA。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_128_CBC_SHA1。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x0ATLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHAOpenSSL 中称为 ECDHE-ECDSA-AES256-SHA。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_256_CBC_SHA1。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x0BTLS_ECDH_RSA_WITH_NULL_SHANSS 中称为 TLS_ECDH_RSA_WITH_NULL_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x0CTLS_ECDH_RSA_WITH_RC4_128_SHANSS 中称为 TLS_ECDH_RSA_WITH_RC4_128_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x0DTLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHANSS 中称为 TLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x0ETLS_ECDH_RSA_WITH_AES_128_CBC_SHANSS 中称为 TLS_ECDH_RSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x0FTLS_ECDH_RSA_WITH_AES_256_CBC_SHANSS 中称为 TLS_ECDH_RSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x10TLS_ECDHE_RSA_WITH_NULL_SHAOpenSSL 中称为 ECDHE-RSA-NULL-SHA。 GnuTLS 中称为 TLS_ECDHE_RSA_NULL_SHA1。 NSS 中称为 TLS_ECDHE_RSA_WITH_NULL_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0x11TLS_ECDHE_RSA_WITH_RC4_128_SHAOpenSSL 中称为 ECDHE-RSA-RC4-SHA。 GnuTLS 中称为 TLS_ECDHE_RSA_ARCFOUR_128_SHA1。 NSS 中称为 TLS_ECDHE_RSA_WITH_RC4_128_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)和IANA 将该套件标记为不建议使用。D
0xC0,0x12TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 ECDHE-RSA-DES-CBC3-SHA。 GnuTLS 中称为 TLS_ECDHE_RSA_3DES_EDE_CBC_SHA1。 NSS 中称为 TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x13TLS_ECDHE_RSA_WITH_AES_128_CBC_SHAOpenSSL 中称为 ECDHE-RSA-AES128-SHA。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_128_CBC_SHA1。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x14TLS_ECDHE_RSA_WITH_AES_256_CBC_SHAOpenSSL 中称为 ECDHE-RSA-AES256-SHA。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_256_CBC_SHA1。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x15TLS_ECDH_anon_WITH_NULL_SHAOpenSSL 中称为 AECDH-NULL-SHA。 GnuTLS 中称为 TLS_ECDH_ANON_NULL_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密、不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x16TLS_ECDH_anon_WITH_RC4_128_SHAOpenSSL 中称为 AECDH-RC4-SHA。 GnuTLS 中称为 TLS_ECDH_ANON_ARCFOUR_128_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x17TLS_ECDH_anon_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 AECDH-DES-CBC3-SHA。 GnuTLS 中称为 TLS_ECDH_ANON_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、64 位分组密码(易受 Sweet32 等生日攻击)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x18TLS_ECDH_anon_WITH_AES_128_CBC_SHAOpenSSL 中称为 AECDH-AES128-SHA。 GnuTLS 中称为 TLS_ECDH_ANON_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x19TLS_ECDH_anon_WITH_AES_256_CBC_SHAOpenSSL 中称为 AECDH-AES256-SHA。 GnuTLS 中称为 TLS_ECDH_ANON_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x1ATLS_SRP_SHA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 SRP-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x1BTLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 SRP-RSA-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_RSA_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x1CTLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 SRP-DSS-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_DSS_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x1DTLS_SRP_SHA_WITH_AES_128_CBC_SHAOpenSSL 中称为 SRP-AES-128-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x1ETLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHAOpenSSL 中称为 SRP-RSA-AES-128-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_RSA_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x1FTLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHAOpenSSL 中称为 SRP-DSS-AES-128-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_DSS_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x20TLS_SRP_SHA_WITH_AES_256_CBC_SHAOpenSSL 中称为 SRP-AES-256-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x21TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHAOpenSSL 中称为 SRP-RSA-AES-256-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_RSA_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x22TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHAOpenSSL 中称为 SRP-DSS-AES-256-CBC-SHA。 GnuTLS 中称为 TLS_SRP_SHA_DSS_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x23TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256OpenSSL 中称为 ECDHE-ECDSA-AES128-SHA256。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_128_CBC_SHA256。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x24TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384OpenSSL 中称为 ECDHE-ECDSA-AES256-SHA384。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_256_CBC_SHA384。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x25TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x26TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x27TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256OpenSSL 中称为 ECDHE-RSA-AES128-SHA256。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_128_CBC_SHA256。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x28TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384OpenSSL 中称为 ECDHE-RSA-AES256-SHA384。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_256_CBC_SHA384。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x29TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x2ATLS_ECDH_RSA_WITH_AES_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x2B说明TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256OpenSSL 中称为 ECDHE-ECDSA-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_128_GCM_SHA256。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xC0,0x2CTLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384OpenSSL 中称为 ECDHE-ECDSA-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_256_GCM_SHA384。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xC0,0x2DTLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x2ETLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x2F说明TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256OpenSSL 中称为 ECDHE-RSA-AES128-GCM-SHA256。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_128_GCM_SHA256。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xC0,0x30说明TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384OpenSSL 中称为 ECDHE-RSA-AES256-GCM-SHA384。 GnuTLS 中称为 TLS_ECDHE_RSA_AES_256_GCM_SHA384。 NSS 中称为 TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xC0,0x31TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x32TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x33TLS_ECDHE_PSK_WITH_RC4_128_SHAOpenSSL 中称为 ECDHE-PSK-RC4-SHA。 GnuTLS 中称为 TLS_ECDHE_PSK_ARCFOUR_128_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:RC4(其输出偏差导致它在 TLS 中被禁用,RFC 7465)和IANA 将该套件标记为不建议使用。D
0xC0,0x34TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHAOpenSSL 中称为 ECDHE-PSK-3DES-EDE-CBC-SHA。 GnuTLS 中称为 TLS_ECDHE_PSK_3DES_EDE_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:64 位分组密码(易受 Sweet32 等生日攻击)和先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x35TLS_ECDHE_PSK_WITH_AES_128_CBC_SHAOpenSSL 中称为 ECDHE-PSK-AES128-CBC-SHA。 GnuTLS 中称为 TLS_ECDHE_PSK_AES_128_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x36TLS_ECDHE_PSK_WITH_AES_256_CBC_SHAOpenSSL 中称为 ECDHE-PSK-AES256-CBC-SHA。 GnuTLS 中称为 TLS_ECDHE_PSK_AES_256_CBC_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x37TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA256OpenSSL 中称为 ECDHE-PSK-AES128-CBC-SHA256。 GnuTLS 中称为 TLS_ECDHE_PSK_AES_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x38TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA384OpenSSL 中称为 ECDHE-PSK-AES256-CBC-SHA384。 GnuTLS 中称为 TLS_ECDHE_PSK_AES_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x39TLS_ECDHE_PSK_WITH_NULL_SHAOpenSSL 中称为 ECDHE-PSK-NULL-SHA。 GnuTLS 中称为 TLS_ECDHE_PSK_NULL_SHA1。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0x3ATLS_ECDHE_PSK_WITH_NULL_SHA256OpenSSL 中称为 ECDHE-PSK-NULL-SHA256。 GnuTLS 中称为 TLS_ECDHE_PSK_NULL_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0x3BTLS_ECDHE_PSK_WITH_NULL_SHA384OpenSSL 中称为 ECDHE-PSK-NULL-SHA384。 GnuTLS 中称为 TLS_ECDHE_PSK_NULL_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0x3CTLS_RSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x3DTLS_RSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x3ETLS_DH_DSS_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x3FTLS_DH_DSS_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x40TLS_DH_RSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x41TLS_DH_RSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x42TLS_DHE_DSS_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x43TLS_DHE_DSS_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x44TLS_DHE_RSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x45TLS_DHE_RSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x46TLS_DH_anon_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x47TLS_DH_anon_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x48TLS_ECDHE_ECDSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x49TLS_ECDHE_ECDSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x4ATLS_ECDH_ECDSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x4BTLS_ECDH_ECDSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x4CTLS_ECDHE_RSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x4DTLS_ECDHE_RSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x4ETLS_ECDH_RSA_WITH_ARIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x4FTLS_ECDH_RSA_WITH_ARIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x50TLS_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x51TLS_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x52TLS_DHE_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 DHE-RSA-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x53TLS_DHE_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 DHE-RSA-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x54TLS_DH_RSA_WITH_ARIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x55TLS_DH_RSA_WITH_ARIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x56TLS_DHE_DSS_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 DHE-DSS-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x57TLS_DHE_DSS_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 DHE-DSS-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x58TLS_DH_DSS_WITH_ARIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x59TLS_DH_DSS_WITH_ARIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x5ATLS_DH_anon_WITH_ARIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x5BTLS_DH_anon_WITH_ARIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x5CTLS_ECDHE_ECDSA_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 ECDHE-ECDSA-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x5DTLS_ECDHE_ECDSA_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 ECDHE-ECDSA-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x5ETLS_ECDH_ECDSA_WITH_ARIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x5FTLS_ECDH_ECDSA_WITH_ARIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x60TLS_ECDHE_RSA_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 ECDHE-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x61TLS_ECDHE_RSA_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 ECDHE-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x62TLS_ECDH_RSA_WITH_ARIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x63TLS_ECDH_RSA_WITH_ARIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x64TLS_PSK_WITH_ARIA_128_CBC_SHA256TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x65TLS_PSK_WITH_ARIA_256_CBC_SHA384TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x66TLS_DHE_PSK_WITH_ARIA_128_CBC_SHA256TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x67TLS_DHE_PSK_WITH_ARIA_256_CBC_SHA384TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x68TLS_RSA_PSK_WITH_ARIA_128_CBC_SHA256TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x69TLS_RSA_PSK_WITH_ARIA_256_CBC_SHA384TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x6ATLS_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 PSK-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x6BTLS_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 PSK-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x6CTLS_DHE_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 DHE-PSK-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x6DTLS_DHE_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 DHE-PSK-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x6ETLS_RSA_PSK_WITH_ARIA_128_GCM_SHA256OpenSSL 中称为 RSA-PSK-ARIA128-GCM-SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x6FTLS_RSA_PSK_WITH_ARIA_256_GCM_SHA384OpenSSL 中称为 RSA-PSK-ARIA256-GCM-SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x70TLS_ECDHE_PSK_WITH_ARIA_128_CBC_SHA256TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x71TLS_ECDHE_PSK_WITH_ARIA_256_CBC_SHA384TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x72TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 ECDHE-ECDSA-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_ECDHE_ECDSA_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x73TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 ECDHE-ECDSA-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_ECDHE_ECDSA_CAMELLIA_256_CBC_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x74TLS_ECDH_ECDSA_WITH_CAMELLIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x75TLS_ECDH_ECDSA_WITH_CAMELLIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x76TLS_ECDHE_RSA_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 ECDHE-RSA-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_ECDHE_RSA_CAMELLIA_128_CBC_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x77TLS_ECDHE_RSA_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 ECDHE-RSA-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_ECDHE_RSA_CAMELLIA_256_CBC_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x78TLS_ECDH_RSA_WITH_CAMELLIA_128_CBC_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x79TLS_ECDH_RSA_WITH_CAMELLIA_256_CBC_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x7ATLS_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_RSA_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x7BTLS_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_RSA_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x7CTLS_DHE_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x7DTLS_DHE_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_DHE_RSA_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x7ETLS_DH_RSA_WITH_CAMELLIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x7FTLS_DH_RSA_WITH_CAMELLIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x80TLS_DHE_DSS_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x81TLS_DHE_DSS_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_DHE_DSS_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x82TLS_DH_DSS_WITH_CAMELLIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x83TLS_DH_DSS_WITH_CAMELLIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x84TLS_DH_anon_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x85TLS_DH_anon_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_DH_ANON_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:不安全。弱点:不验证服务器身份(主动攻击者可以冒充服务器)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x86TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_ECDHE_ECDSA_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x87TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_ECDHE_ECDSA_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x88TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x89TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x8ATLS_ECDHE_RSA_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_ECDHE_RSA_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x8BTLS_ECDHE_RSA_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_ECDHE_RSA_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0x8CTLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x8DTLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x8ETLS_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_PSK_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x8FTLS_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_PSK_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x90TLS_DHE_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_DHE_PSK_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x91TLS_DHE_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_DHE_PSK_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x92TLS_RSA_PSK_WITH_CAMELLIA_128_GCM_SHA256GnuTLS 中称为 TLS_RSA_PSK_CAMELLIA_128_GCM_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x93TLS_RSA_PSK_WITH_CAMELLIA_256_GCM_SHA384GnuTLS 中称为 TLS_RSA_PSK_CAMELLIA_256_GCM_SHA384。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x94TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 PSK-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_PSK_CAMELLIA_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x95TLS_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 PSK-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_PSK_CAMELLIA_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0x96TLS_DHE_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 DHE-PSK-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_DHE_PSK_CAMELLIA_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x97TLS_DHE_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 DHE-PSK-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_DHE_PSK_CAMELLIA_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)和IANA 将该套件标记为不建议使用。D
0xC0,0x98TLS_RSA_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 RSA-PSK-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_RSA_PSK_CAMELLIA_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x99TLS_RSA_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 RSA-PSK-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_RSA_PSK_CAMELLIA_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)、没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x9ATLS_ECDHE_PSK_WITH_CAMELLIA_128_CBC_SHA256OpenSSL 中称为 ECDHE-PSK-CAMELLIA128-SHA256。 GnuTLS 中称为 TLS_ECDHE_PSK_CAMELLIA_128_CBC_SHA256。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x9BTLS_ECDHE_PSK_WITH_CAMELLIA_256_CBC_SHA384OpenSSL 中称为 ECDHE-PSK-CAMELLIA256-SHA384。 GnuTLS 中称为 TLS_ECDHE_PSK_CAMELLIA_256_CBC_SHA384。TLS 1.0, TLS 1.1, TLS 1.2ecdsa.com 评级:弱。弱点:先 MAC 后加密的 CBC(Lucky Thirteen 等填充预言攻击所利用的结构)。N
0xC0,0x9CTLS_RSA_WITH_AES_128_CCMOpenSSL 中称为 AES128-CCM。 GnuTLS 中称为 TLS_RSA_AES_128_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x9DTLS_RSA_WITH_AES_256_CCMOpenSSL 中称为 AES256-CCM。 GnuTLS 中称为 TLS_RSA_AES_256_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xC0,0x9ETLS_DHE_RSA_WITH_AES_128_CCMOpenSSL 中称为 DHE-RSA-AES128-CCM。 GnuTLS 中称为 TLS_DHE_RSA_AES_128_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0x9FTLS_DHE_RSA_WITH_AES_256_CCMOpenSSL 中称为 DHE-RSA-AES256-CCM。 GnuTLS 中称为 TLS_DHE_RSA_AES_256_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0xA0TLS_RSA_WITH_AES_128_CCM_8OpenSSL 中称为 AES128-CCM8。 GnuTLS 中称为 TLS_RSA_AES_128_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)、IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xA1TLS_RSA_WITH_AES_256_CCM_8OpenSSL 中称为 AES256-CCM8。 GnuTLS 中称为 TLS_RSA_AES_256_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)、IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xA2TLS_DHE_RSA_WITH_AES_128_CCM_8OpenSSL 中称为 DHE-RSA-AES128-CCM8。 GnuTLS 中称为 TLS_DHE_RSA_AES_128_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xA3TLS_DHE_RSA_WITH_AES_256_CCM_8OpenSSL 中称为 DHE-RSA-AES256-CCM8。 GnuTLS 中称为 TLS_DHE_RSA_AES_256_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xA4TLS_PSK_WITH_AES_128_CCMOpenSSL 中称为 PSK-AES128-CCM。 GnuTLS 中称为 TLS_PSK_AES_128_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0xA5TLS_PSK_WITH_AES_256_CCMOpenSSL 中称为 PSK-AES256-CCM。 GnuTLS 中称为 TLS_PSK_AES_256_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC0,0xA6TLS_DHE_PSK_WITH_AES_128_CCMOpenSSL 中称为 DHE-PSK-AES128-CCM。 GnuTLS 中称为 TLS_DHE_PSK_AES_128_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0xA7TLS_DHE_PSK_WITH_AES_256_CCMOpenSSL 中称为 DHE-PSK-AES256-CCM。 GnuTLS 中称为 TLS_DHE_PSK_AES_256_CCM。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xC0,0xA8TLS_PSK_WITH_AES_128_CCM_8OpenSSL 中称为 PSK-AES128-CCM8。 GnuTLS 中称为 TLS_PSK_AES_128_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0xC0,0xA9TLS_PSK_WITH_AES_256_CCM_8OpenSSL 中称为 PSK-AES256-CCM8。 GnuTLS 中称为 TLS_PSK_AES_256_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0xC0,0xAATLS_PSK_DHE_WITH_AES_128_CCM_8OpenSSL 中称为 DHE-PSK-AES128-CCM8。 GnuTLS 中称为 TLS_DHE_PSK_AES_128_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xABTLS_PSK_DHE_WITH_AES_256_CCM_8OpenSSL 中称为 DHE-PSK-AES256-CCM8。 GnuTLS 中称为 TLS_DHE_PSK_AES_256_CCM_8。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用和8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。D
0xC0,0xACTLS_ECDHE_ECDSA_WITH_AES_128_CCMOpenSSL 中称为 ECDHE-ECDSA-AES128-CCM。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_128_CCM。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xADTLS_ECDHE_ECDSA_WITH_AES_256_CCMOpenSSL 中称为 ECDHE-ECDSA-AES256-CCM。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_256_CCM。TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xAETLS_ECDHE_ECDSA_WITH_AES_128_CCM_8OpenSSL 中称为 ECDHE-ECDSA-AES128-CCM8。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_128_CCM_8。TLS 1.2ecdsa.com 评级:安全。弱点:8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0xC0,0xAFTLS_ECDHE_ECDSA_WITH_AES_256_CCM_8OpenSSL 中称为 ECDHE-ECDSA-AES256-CCM8。 GnuTLS 中称为 TLS_ECDHE_ECDSA_AES_256_CCM_8。TLS 1.2ecdsa.com 评级:安全。弱点:8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0xC0,0xB0TLS_ECCPWD_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xB1TLS_ECCPWD_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xB2TLS_ECCPWD_WITH_AES_128_CCM_SHA256TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xB3TLS_ECCPWD_WITH_AES_256_CCM_SHA384TLS 1.2ecdsa.com 评级:安全。未发现弱点。N
0xC0,0xB4TLS_SHA256_SHA256OpenSSL 中称为 TLS_SHA256_SHA256。TLS 1.3ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC0,0xB5TLS_SHA384_SHA384OpenSSL 中称为 TLS_SHA384_SHA384。TLS 1.3ecdsa.com 评级:不安全。弱点:记录未加密和IANA 将该套件标记为不建议使用。D
0xC1,0x00TLS_GOSTR341112_256_WITH_KUZNYECHIK_CTR_OMACOpenSSL 中称为 GOST2012-KUZNYECHIK-KUZNYECHIKOMAC。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC1,0x01TLS_GOSTR341112_256_WITH_MAGMA_CTR_OMACOpenSSL 中称为 GOST2012-MAGMA-MAGMAOMAC。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC1,0x02TLS_GOSTR341112_256_WITH_28147_CNT_IMITGnuTLS 中称为 TLS_GOSTR341112_256_28147_CNT_IMIT。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xC1,0x03TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_LTLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0xC1,0x04TLS_GOSTR341112_256_WITH_MAGMA_MGM_LTLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0xC1,0x05TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_STLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0xC1,0x06TLS_GOSTR341112_256_WITH_MAGMA_MGM_STLS 1.3ecdsa.com 评级:安全。未发现弱点。N
0xCA,0xCAReserved—N
0xCC,0xA8TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 ECDHE-RSA-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_ECDHE_RSA_CHACHA20_POLY1305。 NSS 中称为 TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xCC,0xA9说明TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 ECDHE-ECDSA-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_ECDHE_ECDSA_CHACHA20_POLY1305。 NSS 中称为 TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xCC,0xAATLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 DHE-RSA-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_DHE_RSA_CHACHA20_POLY1305。 NSS 中称为 TLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xCC,0xABTLS_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 PSK-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_PSK_CHACHA20_POLY1305。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)。N
0xCC,0xACTLS_ECDHE_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 ECDHE-PSK-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_ECDHE_PSK_CHACHA20_POLY1305。TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xCC,0xADTLS_DHE_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 DHE-PSK-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_DHE_PSK_CHACHA20_POLY1305。TLS 1.2ecdsa.com 评级:弱。弱点:IANA 将该套件标记为不建议使用。D
0xCC,0xAETLS_RSA_PSK_WITH_CHACHA20_POLY1305_SHA256OpenSSL 中称为 RSA-PSK-CHACHA20-POLY1305。 GnuTLS 中称为 TLS_RSA_PSK_CHACHA20_POLY1305。TLS 1.2ecdsa.com 评级:弱。弱点:没有前向保密(服务器密钥一旦被盗,过去录下的流量就能被解密)和IANA 将该套件标记为不建议使用。D
0xD0,0x01TLS_ECDHE_PSK_WITH_AES_128_GCM_SHA256TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xD0,0x02TLS_ECDHE_PSK_WITH_AES_256_GCM_SHA384TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xD0,0x03TLS_ECDHE_PSK_WITH_AES_128_CCM_8_SHA256TLS 1.2ecdsa.com 评级:安全。弱点:8 字节认证标签(CCM_8,IANA 不推荐将其用于一般用途)。N
0xD0,0x05TLS_ECDHE_PSK_WITH_AES_128_CCM_SHA256TLS 1.2ecdsa.com 评级:推荐。未发现弱点。Y
0xDA,0xDAReserved—N
0xEA,0xEAReserved—N
0xFA,0xFAReserved—N
未分配和保留的范围 · 76 个条目
范围状态说明
0x001C–0x001DreservedReserved to avoid conflicts with SSLv3
0x0047–0x004FreservedReserved to avoid conflicts with deployed implementations
0x0050–0x0058reservedReserved to avoid conflicts
0x0059–0x005CreservedReserved to avoid conflicts with deployed implementations
0x005D–0x005FunassignedUnassigned
0x0060–0x0066reservedReserved to avoid conflicts with widely deployed implementations
0x0072–0x0083unassignedUnassigned
0x00C8–0x00FEunassignedUnassigned
0x0100–0x09FFunassignedUnassigned
0x0A00–0x0A09unassignedUnassigned
0x0A0B–0x0AFFunassignedUnassigned
0x0B00–0x12FFunassignedUnassigned
0x1300unassignedUnassigned
0x1308–0x13FFunassignedUnassigned
0x1400–0x19FFunassignedUnassigned
0x1A00–0x1A19unassignedUnassigned
0x1A1B–0x1AFFunassignedUnassigned
0x1B00–0x29FFunassignedUnassigned
0x2A00–0x2A29unassignedUnassigned
0x2A2B–0x2AFFunassignedUnassigned
0x2B00–0x39FFunassignedUnassigned
0x3A00–0x3A39unassignedUnassigned
0x3A3B–0x3AFFunassignedUnassigned
0x3B00–0x49FFunassignedUnassigned
0x4A00–0x4A49unassignedUnassigned
0x4A4B–0x4AFFunassignedUnassigned
0x4B00–0x55FFunassignedUnassigned
0x5601–0x56FFunassignedUnassigned
0x5700–0x59FFunassignedUnassigned
0x5A00–0x5A59unassignedUnassigned
0x5A5B–0x5AFFunassignedUnassigned
0x5B00–0x69FFunassignedUnassigned
0x6A00–0x6A69unassignedUnassigned
0x6A6B–0x6AFFunassignedUnassigned
0x6B00–0x79FFunassignedUnassigned
0x7A00–0x7A79unassignedUnassigned
0x7A7B–0x7AFFunassignedUnassigned
0x7B00–0x89FFunassignedUnassigned
0x8A00–0x8A89unassignedUnassigned
0x8A8B–0x8AFFunassignedUnassigned
0x8B00–0x99FFunassignedUnassigned
0x9A00–0x9A99unassignedUnassigned
0x9A9B–0x9AFFunassignedUnassigned
0x9B00–0xA9FFunassignedUnassigned
0xAA00–0xAAA9unassignedUnassigned
0xAAAB–0xAAFFunassignedUnassigned
0xAB00–0xB9FFunassignedUnassigned
0xBA00–0xBAB9unassignedUnassigned
0xBABB–0xBAFFunassignedUnassigned
0xBB00–0xBFFFunassignedUnassigned
0xC000unassignedUnassigned
0xC0B6–0xC0FFunassignedUnassigned
0xC107–0xC1FFunassignedUnassigned
0xC200–0xC9FFunassignedUnassigned
0xCA00–0xCAC9unassignedUnassigned
0xCACB–0xCAFFunassignedUnassigned
0xCB00–0xCBFFunassignedUnassigned
0xCC00–0xCCA7unassignedUnassigned
0xCCAF–0xCCFFunassignedUnassigned
0xCD00–0xCFFFunassignedUnassigned
0xD000unassignedUnassigned
0xD004unassignedUnassigned
0xD006–0xD0FFunassignedUnassigned
0xD100–0xD9FFunassignedUnassigned
0xDA00–0xDAD9unassignedUnassigned
0xDADB–0xDAFFunassignedUnassigned
0xDB00–0xE9FFunassignedUnassigned
0xEA00–0xEAE9unassignedUnassigned
0xEAEB–0xEAFFunassignedUnassigned
0xEB00–0xF9FFunassignedUnassigned
0xFA00–0xFAC9unassignedUnassigned
0xFAFB–0xFAFFunassignedUnassigned
0xFB00–0xFDFFunassignedUnassigned
0xFE00–0xFEFDunassignedUnassigned
0xFEFE–0xFEFFreservedReserved to avoid conflicts with widely deployed implementations
0xFF00–0xFFFFprivateReserved for Private Use

来源:Transport Layer Security (TLS) Parameters(IANA),获取于 2026-10-20。数据许可证:CC0-1.0, Apache-2.0, LGPL-2.1-or-later, MPL-2.0。 TLS Cipher Suites · OpenSSL openssl-4.0.3 include/openssl/tls1.h · OpenSSL openssl-4.0.3 include/openssl/ssl3.h · OpenSSL openssl-4.0.3 ssl/s3_lib.c · GnuTLS 3.8.13 lib/algorithms/ciphersuites.c · NSS NSS_3_131_RTM lib/ssl/sslproto.h · NSS NSS_3_131_RTM lib/ssl/sslinfo.c

重要条目说明

TLS_NULL_WITH_NULL_NULL

首次握手完成之前连接所用的占位套件:没有密钥交换、没有身份验证,也没有任何保护。

TLS_NULL_WITH_NULL_NULL(0x00,0x00)描述 TLS 1.2 连接的初始状态(RFC 5246 §6.1)。它永远不会被协商选中;选择它的服务器存在严重缺陷。

TLS_RSA_WITH_RC4_128_SHA

使用 SHA-1 和 RSA 密钥传输的 RC4 套件,曾是应对 BEAST 的热门选择,现已被 RFC 7465 禁止。

RC4 不受2011年至2013年那些 CBC 攻击的影响,因此一度被推荐使用,但它的密钥流偏差让攻击者能够恢复反复发送的明文,例如 Cookie。RFC 7465 §2 规定客户端不得(MUST NOT)在 ClientHello 中包含 RC4 套件,服务器也不得(MUST NOT)选择它们。

TLS_RSA_WITH_3DES_EDE_CBC_SHA

TLS 1.1 规定必须实现的套件;它的 64 位分组使其易受 Sweet32 生日攻击。

RFC 4346 §9 要求 TLS 1.1 实现支持 TLS_RSA_WITH_3DES_EDE_CBC_SHA(OpenSSL:DES-CBC3-SHA)。三重 DES 的分组只有 64 位,同一密钥加密约 2^32 个分组后,碰撞就会泄露明文;2016年的 Sweet32 攻击正是用这种方式从长时间保持的连接中恢复出了 HTTP Cookie。

它也不具备前向保密。现代库默认禁用它,IANA 也将其标记为不建议使用。

TLS_RSA_WITH_AES_128_CBC_SHA

TLS 1.2 规定必须实现的套件;它没有前向保密、使用 CBC,现已被 RFC 10015 禁止。

RFC 5246 §9 要求每个 TLS 1.2 实现都支持 TLS_RSA_WITH_AES_128_CBC_SHA(OpenSSL:AES128-SHA),因此它是许多旧客户端最后的兜底套件。采用 RSA 密钥传输时,客户端用服务器证书中的公钥加密预主密钥:日后任何人只要获得对应的私钥,就能解密所有录下的会话。

先 MAC 后加密的 CBC 结构使它容易遭受 Lucky Thirteen 等填充预言攻击。RFC 10015 §4 现已规定,在 TLS 1.2 中客户端不得(MUST NOT)提供、服务器不得(MUST NOT)选择 RSA 密钥交换套件。

TLS_EMPTY_RENEGOTIATION_INFO_SCSV

一个信令值,而不是真正的套件:表示客户端支持安全重协商(RFC 5746)。

客户端把 TLS_EMPTY_RENEGOTIATION_INFO_SCSV(0x00,0xFF)放进密码套件列表,在不发送扩展的情况下表明自己支持安全重协商。RFC 5746 §3.3 引入它,是因为有些服务器无法正确处理扩展;它“不能被协商”。这一重协商修复堵住了2009年的攻击:攻击者曾能把自己的数据拼接到客户端重协商后的会话之前。

TLS_AES_128_GCM_SHA256

每个 TLS 1.3 实现都必须支持的密码套件:GCM 模式的 AES-128,密钥调度使用 SHA-256。

RFC 8446 §9.1 规定 TLS_AES_128_GCM_SHA256 是 TLS 1.3 中必须实现的套件,其后继标准 RFC 9846 保留了这一要求。在 TLS 1.3 中,套件只指定 AEAD 和 HKDF 使用的哈希;密钥交换(例如 X25519MLKEM768)和签名(例如 ecdsa_secp256r1_sha256)在各自的扩展中协商。

OpenSSL 用 -ciphersuites 配置 TLS 1.3 套件,而不是用 TLS 1.2 使用的 -cipher 字符串,所以修改服务器的密码套件列表往往不会影响 TLS 1.3。

TLS_AES_256_GCM_SHA384

使用 SHA-384 的 AES-256-GCM:RFC 8446 规定实现应当(SHOULD)支持的两个 TLS 1.3 套件之一。

TLS_AES_256_GCM_SHA384 将 256 位 AES 密钥与密钥调度中的 SHA-384 搭配使用。RFC 8446 §9.1 将它与 TLS_CHACHA20_POLY1305_SHA256 一起列为应当(SHOULD)支持的套件;大多数服务器都提供它,遵循 CNSA 的配置规范则要求使用它。

面对量子攻击者,Grover 算法最多只能把 AES 的有效密钥长度减半,因此 AES-256 仍有充足的安全余量;NIST 认为 AES-128 同样够用,因为这类攻击很难并行化。

TLS_CHACHA20_POLY1305_SHA256

ChaCha20-Poly1305,这个 TLS 1.3 套件在没有 AES 指令的设备上以软件实现也能高速运行。

TLS_CHACHA20_POLY1305_SHA256 使用 ChaCha20 流密码和 Poly1305 消息认证器(RFC 8439)。它无需硬件支持就能以常量时间运行,因此成为没有 AES 指令的移动设备上的首选套件;如果客户端把它列在首位,服务器通常会尊重这一选择。

RFC 8446 §9.1 规定 TLS 1.3 实现应当(SHOULD)支持它。对应的 TLS 1.2 套件是 TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256 和 TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256(RFC 7905)。

TLS_AES_128_CCM_SHA256

用于 TLS 1.3 的 AES-128-CCM,主要用在已经具备 AES-CCM 硬件的受限设备上。

CCM 将 AES-CTR 加密与 AES-CBC-MAC 结合在一起,常见于物联网无线通信。IANA 将 TLS_AES_128_CCM_SHA256 标记为推荐;TLS_AES_128_CCM_8_SHA256 则不同,它的标签只有 8 字节,IANA 不推荐将其用于一般用途。

TLS_FALLBACK_SCSV

一个信令值,告诉服务器客户端正在用更低的协议版本重试(RFC 7507)。

握手失败后改用较旧协议版本重试的客户端,可能被攻击者一路降级到 SSL 3.0,2014年的 POODLE 正是利用了这一点。客户端在这类重试中发送 TLS_FALLBACK_SCSV(0x56,0x00);如果服务器支持的版本高于客户端提供的版本,就会以 inappropriate_fallback 中止握手,而不是继续。TLS 1.3 在 ServerHello.random 中设置的降级哨兵值,使 TLS 1.3 对端之间不再需要这一机制。

TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256

使用 ECDSA 证书时常用的 TLS 1.2 套件:ECDHE 密钥交换、ECDSA 认证和 AES-128-GCM。

TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256(RFC 5289)通过 ECDHE 临时密钥提供前向保密,并用 ECDSA 证书(通常基于 P-256)认证服务器。服务器持有 ECDSA 证书时,浏览器首选的 TLS 1.2 套件就是它。

在 OpenSSL 的密码套件字符串中,它写作 ECDHE-ECDSA-AES128-GCM-SHA256。只有 RSA 证书的服务器无法协商这个套件——TLS 1.2 套件中的认证部分必须与证书的密钥类型一致。

TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256

HTTP/2 要求支持的 TLS 1.2 套件:ECDHE 密钥交换、RSA 认证和 AES-128-GCM。

RFC 9113 §9.2.2 要求使用 TLS 1.2 的 HTTP/2 部署支持搭配 P-256 曲线的 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,这样,同时遵守 HTTP/2 对 TLS 1.2 所加限制的客户端和服务器总能找到共同支持的套件。

OpenSSL 称之为 ECDHE-RSA-AES128-GCM-SHA256。尽管名称中带有 RSA,RSA 密钥只用于对握手签名;会话密钥来自 ECDHE 临时密钥交换,因此该套件具有前向保密。

TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384

最常用的 TLS 1.2 套件的 256 位版本:ECDHE、RSA 认证、AES-256-GCM 以及基于 SHA-384 的 PRF。

几乎所有使用 RSA 证书的 TLS 1.2 服务器都提供 TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384(RFC 5289)。名称中的 SHA384 指定 TLS 1.2 PRF 所用的哈希;GCM 本身不需要单独的 MAC。

TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256

用于 TLS 1.2 的 ChaCha20-Poly1305,采用 ECDHE 密钥交换和 ECDSA 证书(RFC 7905)。

该套件于2016年加入 TLS 1.2,让尚不能提供 TLS 1.3 的服务器也能使用适合软件实现的 ChaCha20-Poly1305 AEAD。IANA 将其标记为推荐。OpenSSL 中的名称是 ECDHE-ECDSA-CHACHA20-POLY1305。

全部注册表