基になる曲線は Mike Hamburg によるもので、p = 2⁴⁴⁸ − 2²²⁴ − 1 上で定義され、コファクターは 4 です。Ed448 は SHAKE256 でハッシュを計算し、常に SigEd448 というドメイン文字列と 0〜255 バイトのコンテキストを前置します。Ed448ph は、メッセージの代わりに 64 バイトの SHAKE256 ダイジェストに署名します。シードと公開鍵は 57 バイト、署名は 114 バイトです。
識別子は、OID 1.3.101.113(RFC 8410)、crv が Ed448 で alg が Ed448 の JOSE の OKP 鍵(RFC 8037、RFC 9864)、COSE −53(RFC 9864)、TLS 1.3 の ed448(0x0808)、OpenPGP v6 のネイティブ鍵(RFC 9580)です。FIPS 186-5 もこれを承認しています。OpenSSH、WebCrypto、WebAuthn のプラットフォーム認証器は対応していません。
Apple M4 Max の 1 コアで、OpenSSL 3.6.5 は 1 秒あたり約 27,500 回の Ed448 署名と約 10,100 回の検証を行い、これは Ed25519 のおよそ半分の速度です。ポリシーで 128 ビットを超える古典的なセキュリティが求められ、すべての当事者が対応している場合に選択してください。長期的な保護には、128 ビットから 224 ビットへの引き上げよりも、ポスト量子暗号への移行のほうが重要です。