0注記 | server_name | server_name(拡張 0)は、TLS 1.3 では ClientHello、EncryptedExtensions、CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 6066RFC 9261 |
1 | max_fragment_length | max_fragment_length(拡張 1)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | N | RFC 6066RFC 8449 |
2 | client_certificate_url | client_certificate_url(拡張 2)は、TLS 1.3 では使用されません。 | Y | RFC 6066 |
3 | trusted_ca_keys | trusted_ca_keys(拡張 3)は、TLS 1.3 では使用されません。 | Y | RFC 6066 |
4 | truncated_hmac | truncated_hmac(拡張 4)は、TLS 1.3 では使用されません。 | D | RFC 6066IESG Action 2018-08-16RFC 9847Tag Size Does Matter: Attacks and Proofs for the TLS Record Protocol |
5 | status_request | status_request(拡張 5)は、TLS 1.3 では ClientHello、CertificateRequest、Certificate にのみ含まれる可能性があります。 | Y | RFC 6066RFC 9846 |
6 | user_mapping | user_mapping(拡張 6)は、TLS 1.3 では使用されません。 | Y | RFC 4681 |
7 | client_authz | client_authz(拡張 7)は、TLS 1.3 では使用されません。 | N | RFC 5878 |
8 | server_authz | server_authz(拡張 8)は、TLS 1.3 では使用されません。 | N | RFC 5878 |
9 | cert_type | cert_type(拡張 9)は、TLS 1.3 では使用されません。 | N | RFC 6091 |
10注記 | supported_groups | supported_groups(拡張 10)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。以前の名前は elliptic_curves です。 | Y | RFC 8422RFC 7919RFC 9846 |
11 | ec_point_formats | ec_point_formats(拡張 11)は、TLS 1.3 では使用されません。 | Y | RFC 8422 |
12 | srp | srp(拡張 12)は、TLS 1.3 では使用されません。 | N | RFC 5054 |
13注記 | signature_algorithms | signature_algorithms(拡張 13)は、TLS 1.3 では ClientHello、CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
14 | use_srtp | use_srtp(拡張 14)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 5764 |
15 | heartbeat | heartbeat(拡張 15)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 6520 |
16注記 | application_layer_protocol_negotiation | application_layer_protocol_negotiation(拡張 16)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 7301 |
17 | status_request_v2 | status_request_v2(拡張 17)は、TLS 1.3 では使用されません。 | Y | RFC 6961 |
18 | signed_certificate_timestamp | signed_certificate_timestamp(拡張 18)は、TLS 1.3 では ClientHello、CertificateRequest、Certificate にのみ含まれる可能性があります。 | N | RFC 6962 |
19 | client_certificate_type | client_certificate_type(拡張 19)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 7250 |
20 | server_certificate_type | server_certificate_type(拡張 20)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 7250 |
21 | padding | padding(拡張 21)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | Y | RFC 7685 |
22 | encrypt_then_mac | encrypt_then_mac(拡張 22)は、TLS 1.3 では使用されません。 | Y | RFC 7366 |
23注記 | extended_main_secret | extended_main_secret(拡張 23)は、TLS 1.3 では使用されません。 | Y | RFC 7627RFC 9846 |
24 | token_binding | token_binding(拡張 24)は、TLS 1.3 では使用されません。 | Y | RFC 8472 |
25 | cached_info | cached_info(拡張 25)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 7924RFC 9846 |
26 | tls_lts | tls_lts(拡張 26)は、TLS 1.3 では使用されません。 | N | draft-gutmann-tls-lts-11 |
27 | compress_certificate | compress_certificate(拡張 27)は、TLS 1.3 では ClientHello、CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 8879 |
28 | record_size_limit | record_size_limit(拡張 28)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 8449 |
29 | pwd_protect | pwd_protect(拡張 29)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | N | RFC 8492 |
30 | pwd_clear | pwd_clear(拡張 30)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | N | RFC 8492 |
31 | password_salt | password_salt(拡張 31)は、TLS 1.3 では ClientHello、ServerHello、HelloRetryRequest にのみ含まれる可能性があります。 | N | RFC 8492 |
32 | ticket_pinning | ticket_pinning(拡張 32)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | N | RFC 8672 |
33 | tls_cert_with_extern_psk | tls_cert_with_extern_psk(拡張 33)は、TLS 1.3 では ClientHello、ServerHello にのみ含まれる可能性があります。 | N | RFC 9973 |
34 | delegated_credential | delegated_credential(拡張 34)は、TLS 1.3 では ClientHello、CertificateRequest、Certificate にのみ含まれる可能性があります。 | Y | RFC 9345 |
35 | session_ticket | session_ticket(拡張 35)は、TLS 1.3 では使用されません。以前の名前は SessionTicket TLS です。 | Y | RFC 5077RFC 8447 |
36 | TLMSP | TLMSP(拡張 36)は、TLS 1.3 では使用されません。 | N | ETSI TS 103 523-2 |
37 | TLMSP_proxying | TLMSP_proxying(拡張 37)は、TLS 1.3 では使用されません。 | N | ETSI TS 103 523-2 |
38 | TLMSP_delegate | TLMSP_delegate(拡張 38)は、TLS 1.3 では使用されません。 | N | ETSI TS 103 523-2 |
39 | supported_ekt_ciphers | supported_ekt_ciphers(拡張 39)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 8870 |
41 | pre_shared_key | pre_shared_key(拡張 41)は、TLS 1.3 では ClientHello、ServerHello にのみ含まれる可能性があります。 | Y | RFC 9846 |
42 | early_data | early_data(拡張 42)は、TLS 1.3 では ClientHello、EncryptedExtensions、NewSessionTicket にのみ含まれる可能性があります。 | Y | RFC 9846 |
43 | supported_versions | supported_versions(拡張 43)は、TLS 1.3 では ClientHello、ServerHello、HelloRetryRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
44 | cookie | cookie(拡張 44)は、TLS 1.3 では ClientHello、HelloRetryRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
45 | psk_key_exchange_modes | psk_key_exchange_modes(拡張 45)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | Y | RFC 9846 |
47 | certificate_authorities | certificate_authorities(拡張 47)は、TLS 1.3 では ClientHello、CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
48 | oid_filters | oid_filters(拡張 48)は、TLS 1.3 では CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
49 | post_handshake_auth | post_handshake_auth(拡張 49)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | Y | RFC 9846 |
50 | signature_algorithms_cert | signature_algorithms_cert(拡張 50)は、TLS 1.3 では ClientHello、CertificateRequest にのみ含まれる可能性があります。 | Y | RFC 9846 |
51注記 | key_share | key_share(拡張 51)は、TLS 1.3 では ClientHello、ServerHello、HelloRetryRequest にのみ含まれる可能性があります。 | Y | RFC 9846RFC Errata 5483 |
52 | transparency_info | transparency_info(拡張 52)は、TLS 1.3 では ClientHello、CertificateRequest、Certificate にのみ含まれる可能性があります。 | Y | RFC 9162 |
53 | connection_id | connection_id(拡張 53)は、TLS 1.3 では使用されません。DTLS にのみ適用されます。このコードポイントは非推奨です。 | D | RFC 9146RFC 9847 |
54 | connection_id | connection_id(拡張 54)は、TLS 1.3 では ClientHello、ServerHello にのみ含まれる可能性があります。DTLS にのみ適用されます。 | N | RFC 9146 |
55 | external_id_hash | external_id_hash(拡張 55)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 8844 |
56 | external_session_id | external_session_id(拡張 56)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 8844 |
57 | quic_transport_parameters | quic_transport_parameters(拡張 57)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 9001 |
58 | ticket_request | ticket_request(拡張 58)は、TLS 1.3 では ClientHello、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 9149 |
59 | dnssec_chain | dnssec_chain(拡張 59)は、TLS 1.3 では ClientHello、Certificate にのみ含まれる可能性があります。 | N | RFC 9102RFC Errata 6860 |
60 | sequence_number_encryption_algorithms | sequence_number_encryption_algorithms(拡張 60)は、TLS 1.3 では ClientHello、HelloRetryRequest、ServerHello にのみ含まれる可能性があります。DTLS にのみ適用されます。 | N | draft-pismenny-tls-dtls-plaintext-sequence-number-01 |
61 | rrc | rrc(拡張 61)は、TLS 1.3 では ClientHello、ServerHello にのみ含まれる可能性があります。DTLS にのみ適用されます。 | N | RFC 9853 |
62 | tls_flags | tls_flags(拡張 62)は、TLS 1.3 では ClientHello、ServerHello、HelloRetryRequest、EncryptedExtensions、CertificateRequest、Certificate、NewSessionTicket にのみ含まれる可能性があります。 | N | draft-ietf-tls-tlsflags-14 |
2570 | Reserved | 0x0A0A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
6682 | Reserved | 0x1A1A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
10794 | Reserved | 0x2A2A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
14906 | Reserved | 0x3A3A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
19018 | Reserved | 0x4A4A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
23130 | Reserved | 0x5A5A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
27242 | Reserved | 0x6A6A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
31354 | Reserved | 0x7A7A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
35466 | Reserved | 0x8A8A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
39578 | Reserved | 0x9A9A は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
43690 | Reserved | 0xAAAA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
47802 | Reserved | 0xBABA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
51914 | Reserved | 0xCACA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
56026 | Reserved | 0xDADA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
60138 | Reserved | 0xEAEA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
64250 | Reserved | 0xFAFA は「TLS ExtensionType」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。 | N | RFC 8701 |
64768 | ech_outer_extensions | ech_outer_extensions(拡張 64768)は、TLS 1.3 では ClientHello にのみ含まれる可能性があります。 | Y | RFC 9849 |
65037注記 | encrypted_client_hello | encrypted_client_hello(拡張 65037)は、TLS 1.3 では ClientHello、HelloRetryRequest、EncryptedExtensions にのみ含まれる可能性があります。 | Y | RFC 9849 |
65281 | renegotiation_info | renegotiation_info(拡張 65281)は、TLS 1.3 では使用されません。 | Y | RFC 5746 |