跳到主要内容
ecdsa.com

JWA(JSON Web 算法)

RFC 7518:定义 JWS、JWE 和 JWK 使用的算法标识符和参数,例如 HS256、RS256、ES256、PS256、RSA-OAEP、ECDH-ES 和 A256GCM。
其他写法JSON Web AlgorithmsRFC 7518ES512ES384

它的实现要求(§3.1)很能说明问题:HS256 是唯一标为必需(Required)的 JWS 算法,RS256 为推荐(Recommended),ES256 为推荐+(Recommended+,预计将变为必需);PS256、其他 ES 和 RS 变体以及 none 为可选(Optional)。值得注意的规则:HMAC 密钥长度必须至少等于哈希输出长度(§3.2);ECDSA 签名采用原始 r‖s 格式(§3.4);RSA 密钥必须至少为 2048 位(§3.3);ES512 使用 P-521。

对于 JWE,它定义了密钥管理算法(RSA1_5、RSA-OAEP、RSA-OAEP-256、A128KW~A256KW、dir、ECDH-ES 和 ECDH-ES+AxxxKW、AxxxGCMKW、PBES2-HS256+A128KW 等)和内容加密算法(A128CBC-HS256、A192CBC-HS384、A256CBC-HS512、A128GCM、A192GCM、A256GCM)。新算法会登记到 IANA 注册表中,包括 ES256K(RFC 8812)、Ed25519 和 Ed448(RFC 9864),以及仍处于草案阶段的 ML-DSA。

标准与参考资料

全部术语