Pular para o conteúdo
ecdsa.com

JWA (JSON Web Algorithms)

A RFC 7518, que define os identificadores e os parâmetros de algoritmo usados por JWS, JWE e JWK, como HS256, RS256, ES256, PS256, RSA-OAEP, ECDH-ES e A256GCM.
Também escrito comoJSON Web AlgorithmsRFC 7518ES512ES384

Os requisitos de implementação da especificação (§3.1) são reveladores: HS256 é o único algoritmo JWS marcado como obrigatório (Required), RS256 é recomendado (Recommended) e ES256 é Recommended+ (deve passar a obrigatório); PS256, as outras variantes ES e RS e none são opcionais (Optional). Regras notáveis: as chaves HMAC devem ter pelo menos o tamanho da saída do hash (§3.2); as assinaturas ECDSA são r‖s brutas (§3.4); as chaves RSA devem ter pelo menos 2048 bits (§3.3); ES512 usa P-521.

Para o JWE, ela define o gerenciamento de chaves (RSA1_5, RSA-OAEP, RSA-OAEP-256, A128KW–A256KW, dir, ECDH-ES e ECDH-ES+AxxxKW, AxxxGCMKW, PBES2-HS256+A128KW e similares) e a criptografia do conteúdo (A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM). É no registro da IANA que entram os novos algoritmos, incluindo ES256K (RFC 8812), Ed25519 e Ed448 (RFC 9864) e, em rascunhos, ML-DSA.

Padrões e referências

Todos os termos