Перейти к содержимому
ecdsa.com

JWA (JSON Web Algorithms)

RFC 7518, который определяет идентификаторы и параметры алгоритмов для JWS, JWE и JWK, например HS256, RS256, ES256, PS256, RSA-OAEP, ECDH-ES и A256GCM.
Другие написанияJSON Web AlgorithmsRFC 7518ES512ES384

Требования к реализациям (§ 3.1) показательны: HS256 — единственный алгоритм JWS с пометкой Required (обязательный), RS256 помечен как Recommended (рекомендуемый), а ES256 — как Recommended+ (ожидается, что он станет обязательным); PS256, остальные варианты ES и RS и none — Optional (необязательные). Важные правила: ключи HMAC должны быть не короче выхода хеш-функции (§ 3.2); подписи ECDSA записываются в формате raw r‖s (§ 3.4); ключи RSA должны быть не короче 2048 бит (§ 3.3); ES512 использует P-521.

Для JWE он определяет алгоритмы управления ключами (RSA1_5, RSA-OAEP, RSA-OAEP-256, A128KW–A256KW, dir, ECDH-ES и ECDH-ES+AxxxKW, AxxxGCMKW, PBES2-HS256+A128KW и родственные) и шифрования содержимого (A128CBC-HS256, A192CBC-HS384, A256CBC-HS512, A128GCM, A192GCM, A256GCM). Новые алгоритмы попадают в реестр IANA: среди них ES256K (RFC 8812), Ed25519 и Ed448 (RFC 9864), а в черновиках — ML-DSA.

Стандарты и ссылки

Все термины