JOSE, JWK and COSE
JOSE header parameters for JWS and JWE
Registered JWS and JWE header parameters such as alg, kid, typ, crit, jwk and x5c, with what each one means, where it is registered and the defining document.
35 of 35 shown
JOSE header parameters · 35 entries
Registered JWS and JWE header parameters.
| Name | Description | Registered for | References |
|---|---|---|---|
alg | Algorithm | JWE, JWS | RFC 7515, Section 4.1.1RFC 7516, Section 4.1.1 |
apu | Agreement PartyUInfo | JWE | RFC 7518, Section 4.6.1.2 |
apv | Agreement PartyVInfo | JWE | RFC 7518, Section 4.6.1.3 |
aud | Audience | JWE | RFC 7519, Section 4.1.3 |
b64 | Base64url-Encode Payload | JWS | RFC 7797, Section 3 |
client_id | This header contains a Client Identifier. A Client Identifier is used in OAuth to identify a certain client. It is defined in [RFC 6749, Section 2.2]. | JWS | RFC 6749 |
crit | Critical | JWE, JWS | RFC 7515, Section 4.1.11RFC 7516, Section 4.1.13 |
cty | Content Type | JWE, JWS | RFC 7515, Section 4.1.10RFC 7516, Section 4.1.12 |
ek | A base64url-encoded encapsulated secret, as defined in [draft-ietf-hpke-hpke-03, Section 5] | JWE | RFC-ietf-jose-hpke-encrypt-22, Section 4.1 |
enc | Encryption Algorithm | JWE | RFC 7516, Section 4.1.2 |
epk | Ephemeral Public Key | JWE | RFC 7518, Section 4.6.1.1 |
iheSSId | The iheSSId header parameter's value shall specify the SubmissionSet.uniqueId as per [https://profiles.ihe.net/ITI/TF/Volume3/ch-4.2.html#4.2.3.3.12]. | JWS | profiles.ihe.net/ITI/DSGj/Volume3/ch-5.10.html#5.10 |
iss | Issuer | JWE | RFC 7519, Section 4.1.1 |
iv | Initialization Vector | JWE | RFC 7518, Section 4.7.1.1 |
jku | JWK Set URL | JWE, JWS | RFC 7515, Section 4.1.2RFC 7516, Section 4.1.4 |
jwk | JSON Web Key | JWE, JWS | RFC 7515, Section 4.1.3RFC 7516, Section 4.1.5 |
jwt | This header contains a JWT. Processing rules MAY depend on the typ header value of the respective JWT. | JWS | OpenID for Verifiable Presentations 1.0, Section 12 |
kid | Key ID | JWE, JWS | RFC 7515, Section 4.1.4RFC 7516, Section 4.1.6 |
nonce | Nonce | JWE, JWS | RFC 8555, Section 6.5.2 |
p2c | PBES2 Count | JWE | RFC 7518, Section 4.8.1.2 |
p2s | PBES2 Salt Input | JWE | RFC 7518, Section 4.8.1.1 |
peer_trust_chain | OpenID Federation Peer Trust Chain | JWS | OpenID Federation 1.0, Section 4.4 |
ppt | PASSporT extension identifier | JWS | RFC 8225, Section 8.1 |
psk_id | A base64url-encoded key identifier (kid) for the pre-shared key, as defined in [draft-ietf-hpke-hpke-03, Section 5.1.2] | JWE | RFC-ietf-jose-hpke-encrypt-22, Section 4 |
sub | Subject | JWE | RFC 7519, Section 4.1.2 |
svt | Signature Validation Token | JWS | RFC 9321 |
tag | Authentication Tag | JWE | RFC 7518, Section 4.7.1.2 |
trust_chain | OpenID Federation Trust Chain | JWS | OpenID Federation 1.0, Section 4.3 |
typ | Type | JWE, JWS | RFC 7515, Section 4.1.9RFC 7516, Section 4.1.11 |
url | URL | JWE, JWS | RFC 8555, Section 6.4.1 |
x5c | X.509 Certificate Chain | JWE, JWS | RFC 7515, Section 4.1.6RFC 7516, Section 4.1.8 |
x5t | X.509 Certificate SHA-1 Thumbprint | JWE, JWS | RFC 7515, Section 4.1.7RFC 7516, Section 4.1.9 |
x5t#S256 | X.509 Certificate SHA-256 Thumbprint | JWE, JWS | RFC 7515, Section 4.1.8RFC 7516, Section 4.1.10 |
x5u | X.509 URL | JWE, JWS | RFC 7515, Section 4.1.5RFC 7516, Section 4.1.7 |
zip | Compression Algorithm | JWE | RFC 7516, Section 4.1.3 |
Source: JSON Object Signing and Encryption (JOSE) (IANA), retrieved 2026-10-20. Data license: CC0-1.0. JSON Web Signature and Encryption Header Parameters