Saltar al contenido
ecdsa.com

TLS 1.2

La versión de TLS de 2008 (RFC 5246), todavía ampliamente admitida, que introdujo los conjuntos de cifrado AEAD y SHA-256, pero que necesita dos viajes de ida y vuelta y permite opciones débiles que TLS 1.3 eliminó.
También se escribeTLS 1.2TLSv1.2RFC 5246

Su handshake envía los certificados en claro, negocia el intercambio de claves a través del nombre del conjunto de cifrado y, en su modo RSA estático, no ofrece forward secrecy. Una configuración segura implica ECDHE (o DHE) con conjuntos AEAD, el secreto maestro extendido (extended master secret, RFC 7627), renegotiation_info y firmas SHA-256 o mejores, como recomienda el RFC 9325. El RFC 9846 (julio de 2026) deja obsoleto el RFC 5246 y establece nuevos requisitos para las implementaciones de TLS 1.2.

Los ataques a lo largo de su vida se dirigieron a funciones opcionales o heredadas: BEAST y Lucky Thirteen (CBC), los sesgos de RC4, el triple handshake (corregido por el secreto maestro extendido), Logjam y FREAK (claves de exportación, export-grade), ROBOT (transporte de claves RSA) y SWEET32 (cifrados por bloques de 64 bits). Ninguno rompe una conexión TLS 1.2 limitada a ECDHE y AEAD.

Mantén TLS 1.2 habilitado para los clientes antiguos si es imprescindible, junto a 1.3; el intercambio de claves híbrido poscuántico solo existe en TLS 1.3, así que las conexiones que recurren a 1.2 siguen siendo clásicas.

Estándares y referencias

Todos los términos