Zum Inhalt springen
ecdsa.com

DoH (DNS over HTTPS)

Das Protokoll aus RFC 8484, das DNS-Abfragen und -Antworten in HTTPS-Anfragen transportiert (Medientyp application/dns-message), sie so vor Beobachtern auf dem Übertragungsweg verbirgt und Webanwendungen Namen direkt auflösen lässt.
Auch geschrieben alsDNS over HTTPSRFC 8484dns-query

Eine Abfrage ist das binäre DNS-Wire-Format, gesendet per POST oder base64url-kodiert im Parameter dns bei GET, an eine URL wie https://cloudflare-dns.com/dns-query oder https://dns.google/dns-query; mehrere Anbieter bieten zusätzlich eine JSON-API an. Browser nutzen DoH zur Namensauflösung, wenn es konfiguriert ist oder der System-Resolver es unterstützt; DNS over TLS (RFC 7858, Port 853) und DNS over QUIC (RFC 9250) sind die Alternativen.

DoH verschlüsselt den Weg zum Resolver, authentifiziert die Daten aber nicht so, wie DNSSEC es tut, und der Resolver sieht weiterhin jede Abfrage. Für Tools ist DoH ein bequemer Weg, öffentliche Einträge (CAA, TLSA, DNSKEY, TXT für DKIM und DMARC) aus dem Browser abzurufen; die serverseitig unterstützten DNS-Prüfungen dieser Website rufen auf diesem Weg nur öffentliche Namen ab.

Standards und Quellen

Alle Begriffe