Перейти к содержимому
ecdsa.com

DoH (DNS поверх HTTPS)

Протокол из RFC 8484, который передаёт DNS-запросы и ответы внутри HTTPS-запросов (тип содержимого application/dns-message), скрывает их от наблюдателей на пути трафика и позволяет веб-приложениям разрешать имена напрямую.
Другие написанияDNS over HTTPSRFC 8484dns-query

Запрос — это DNS-сообщение в двоичном формате, которое отправляют методом POST или кодируют в base64url и передают в параметре GET с именем dns на URL вроде https://cloudflare-dns.com/dns-query или https://dns.google/dns-query; некоторые провайдеры также предлагают JSON API. Браузеры используют DoH для разрешения имён, если это включено в настройках или если его поддерживает системный резолвер; альтернативы — DNS поверх TLS (RFC 7858, порт 853) и DNS поверх QUIC (RFC 9250).

DoH шифрует канал до резолвера, но не аутентифицирует данные так, как это делает DNSSEC, и резолвер по-прежнему видит каждый запрос. Для инструментов DoH — удобный способ получать из браузера общедоступные записи (CAA, TLSA, DNSKEY, TXT для DKIM и DMARC); серверные DNS-проверки этого сайта запрашивают таким способом только общедоступные имена.

Стандарты и ссылки

Все термины